summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm28
1 files changed, 4 insertions, 24 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 86281b9320..d83211ede2 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -59,7 +59,7 @@
(define-public cups-filters
(package
(name "cups-filters")
- (version "1.27.1")
+ (version "1.27.4")
(source(origin
(method url-fetch)
(uri
@@ -67,7 +67,7 @@
"cups-filters-" version ".tar.xz"))
(sha256
(base32
- "0dpn4rkmrdprkhlnpih5dzrn4fxzj20k42d516kx4qx0g5l74lrm"))
+ "110b1xhb5vfpcx0zq9kkas7pj281skx5dpnnr22idx509jfdzj8b"))
(modules '((guix build utils)))
(snippet
;; install backends, banners and filters to cups-filters output
@@ -125,12 +125,6 @@
(("/usr/local/lib/cups/filter")
(string-append out "/lib/cups/filter")))
#t)))
- (add-after 'unpack 'patch-for-poppler
- (lambda _
- (substitute* "filter/pdf.cxx"
- (("GooString \\*field_name;" m)
- (string-append "const " m)))
- #t))
(add-after 'install 'wrap-filters
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Some filters expect to find 'gs' in $PATH. We cannot
@@ -187,9 +181,8 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
;; satisfy this dependency.
(define-public cups-minimal
(package
- (replacement cups-minimal-2.3.3)
(name "cups-minimal")
- (version "2.3.1")
+ (version "2.3.3")
(source
(origin
(method url-fetch)
@@ -197,7 +190,7 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
version "/cups-" version "-source.tar.gz"))
(sha256
(base32
- "1kkpmj17205j8w9hdff2bfpk6lwdmr3gx0j4r35nhgvya24rvjhv"))))
+ "1vpk0b2vq830f8fvf9z8qjsm5k141i7pi8djbinpnr78pi4dj7r6"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -250,19 +243,6 @@ device-specific programs to convert and print many types of files.")
;; CUPS is Apache 2.0 with exceptions, see the NOTICE file.
(license license:asl2.0)))
-(define-public cups-minimal-2.3.3
- (package
- (inherit cups-minimal)
- (version "2.3.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/apple/cups/releases/download/v"
- version "/cups-" version "-source.tar.gz"))
- (sha256
- (base32
- "1vpk0b2vq830f8fvf9z8qjsm5k141i7pi8djbinpnr78pi4dj7r6"))))))
-
(define-public cups
(package/inherit cups-minimal
(name "cups")