summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm43
1 files changed, 10 insertions, 33 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index d82d94abff..6afc870b41 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -63,16 +63,16 @@
(define-public curl
(package
(name "curl")
- (version "7.79.1")
- (replacement curl-7.84.0)
+ (version "7.84.0")
(source (origin
(method url-fetch)
(uri (string-append "https://curl.se/download/curl-"
version ".tar.xz"))
(sha256
(base32
- "129n9hi7rbg3s112chyadhp4y27ppb5i65n12wm77aw2255zf1h6"))
- (patches (search-patches "curl-use-ssl-cert-env.patch"))))
+ "1f2xgj0wvys9xw50h7vcbaraavjr9rxx9n06x2xfbgs7ym1qn49d"))
+ (patches (search-patches "curl-use-ssl-cert-env.patch"
+ "curl-easy-lock.patch"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
@@ -103,6 +103,12 @@
"--disable-static")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'tweak-lib3026-test
+ (lambda _
+ ;; Have that test create a hundred threads, not a thousand.
+ (substitute* "tests/libtest/lib3026.c"
+ (("NUM_THREADS .*$")
+ "NUM_THREADS 100\n"))))
(add-after 'unpack 'do-not-record-configure-flags
(lambda _
;; Do not save the configure options to avoid unnecessary references.
@@ -141,35 +147,6 @@ tunneling, and so on.")
"See COPYING in the distribution."))
(home-page "https://curl.haxx.se/")))
-;; Replacement package with fixes for multiple vulnerabilities.
-;; See <https://curl.se/docs/security.html>.
-(define curl-7.84.0
- (package
- (inherit curl)
- (version "7.84.0")
- (source (origin
- (inherit (package-source curl))
- (uri (string-append "https://curl.se/download/curl-"
- version ".tar.xz"))
- (sha256
- (base32
- "1f2xgj0wvys9xw50h7vcbaraavjr9rxx9n06x2xfbgs7ym1qn49d"))
- (patches (append (origin-patches (package-source curl))
- (search-patches "curl-easy-lock.patch")))))
- (arguments (substitute-keyword-arguments (package-arguments curl)
- ((#:phases phases)
- (cond
- ((not (target-64bit?))
- #~(modify-phases #$phases
- (add-after 'unpack 'tweak-lib3026-test
- (lambda _
- ;; Have that test create a hundred threads, not a
- ;; thousand.
- (substitute* "tests/libtest/lib3026.c"
- (("NUM_THREADS .*$")
- "NUM_THREADS 100\n"))))))
- (else phases)))))))
-
(define-public curl-minimal
(deprecated-package "curl-minimal" curl))