summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm106
1 files changed, 95 insertions, 11 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 3269d4a2aa..4fa8670cad 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -61,6 +61,7 @@
;;; Copyright © 2021, 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Felix Gruber <felgru@posteo.ne
;;; Copyright © 2023 Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2023 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -106,6 +107,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages golang-check)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -2968,14 +2970,16 @@ can autogenerate peewee models using @code{pwiz}, a model generator.")
(define-public python-pypika-tortoise
(package
(name "python-pypika-tortoise")
- (version "0.1.5")
+ (version "0.1.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pypika-tortoise" version))
(sha256
- (base32 "0j20574s2yrq8d7fav3816vj1nfpihkm2mj8jzh2ank4zixp8brf"))))
- (build-system python-build-system)
+ (base32 "0dmzpsnlqjjz0vm0r9xjk69xfsm235bpnk3jccr8ww4s8y7qc0nq"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list poetry))
(home-page "https://github.com/tortoise/pypika-tortoise")
(synopsis "Pypika fork for tortoise-orm")
(description "Pypika-tortoise is a fork of pypika which has been
@@ -3070,20 +3074,25 @@ of PyMySQL. @code{aiomysql} tries to preserve the same API as the
(define-public python-tortoise-orm
(package
(name "python-tortoise-orm")
- (version "0.19.1")
+ (version "0.20.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "tortoise-orm" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tortoise/tortoise-orm")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "17yk71dlx5ai98i6ivqgsplkwivdxackz9jfn6z42bpcdgbpiwhg"))))
- (build-system python-build-system)
+ (base32 "19rgyvs2y9gn27x71y7djdz6rb6bszgvprv55q1hr4266wy6g999"))))
+ (build-system pyproject-build-system)
;; The test suite relies on asynctest, which is abandoned and doesn't
;; support Python >= 3.8.
(arguments '(#:tests? #f))
+ (native-inputs
+ (list poetry))
(propagated-inputs
(list python-aiomysql
- python-aiosqlite
+ python-aiosqlite-0.17
python-asyncmy
python-asyncpg
python-ciso8601
@@ -3101,6 +3110,48 @@ engraved in its design that you are working not with just tables, you work
with relational data.")
(license license:asl2.0)))
+(define-public aerich
+ (package
+ (name "aerich")
+ (version "0.7.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tortoise/aerich")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pcy945bg890p12s7cyw0mg7hxwsxyy570j600sbf7kwj2d3lilg"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list poetry
+ python-bandit
+ python-cryptography
+ python-isort
+ python-pydantic
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-mock
+ python-pytest-xdist))
+ (propagated-inputs
+ (list python-asyncmy
+ python-asyncpg
+ python-click
+ python-ddlparse
+ python-dictdiffer
+ python-tomlkit
+ python-tortoise-orm))
+ (home-page "https://github.com/tortoise/aerich")
+ (synopsis "Database migrations tool for Tortoise @acronym{ORM, Object Relational
+Mapper}")
+ (description
+ "This package provides @code{aerich}, a Python database migrations tool
+for Tortoise @acronym{ORM, Object Relational Mapper}. It can be used both
+programmatically or as a standalone CLI application.")
+ (license license:asl2.0)))
+
(define-public sqlcipher
(package
(name "sqlcipher")
@@ -3541,7 +3592,11 @@ You might also want to install the following optional dependencies:
(uri (pypi-uri "alchemy-mock" version))
(sha256
(base32
- "0ylxygl3bcdapzz529n8wgk7vx9gjwb3ism564ypkpd7dbsw653r"))))
+ "0ylxygl3bcdapzz529n8wgk7vx9gjwb3ism564ypkpd7dbsw653r"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ (substitute* "alchemy_mock/comparison.py"
+ (("collections\\.Mapping") "collections.abc.Mapping"))))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -3773,6 +3828,33 @@ async versions of all the standard connection and cursor methods, and context
managers for automatically closing connections.")
(license license:expat)))
+(define-public python-aiosqlite-0.17
+ (package
+ (inherit python-aiosqlite)
+ (version "0.17.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/omnilib/aiosqlite")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name (package-name python-aiosqlite)
+ version))
+ (sha256
+ (base32
+ "1agh7b9g7rgryvb8flph85i8m80ai1rinpljxzlsrs0s0y616qgg"))))
+ (build-system pyproject-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "python" "-m" "unittest" "aiosqlite.tests")
+ (format #t "test suite not run~%")))))))
+ (propagated-inputs
+ (list python-typing-extensions))
+ (native-inputs
+ (list python-flit-core python-aiounittest))))
+
(define-public python-databases
(package
(name "python-databases")
@@ -4919,7 +5001,9 @@ The drivers officially supported by @code{libdbi} are:
`(#:configure-flags
;; C++11 (-DSOCI_CXX11) is OFF by default. hyperledger-iroha needs it.
(list "-DCMAKE_CXX_STANDARD=17"
- "-DSOCI_LIBDIR=lib")
+ "-DSOCI_LIBDIR=lib"
+ ;; This is for relocation when linking statically
+ "-DCMAKE_CXX_FLAGS=-fPIE")
#:tests? #f)) ; may require running database management systems
(synopsis "C++ Database Access Library")
(description