summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm39
1 files changed, 28 insertions, 11 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 86cf8836b3..fdee887af7 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
@@ -86,6 +86,7 @@
("automake" ,automake)
("gettext" ,gnu-gettext)
("libtool" ,libtool)
+ ("pcre" ,pcre "bin") ;for 'pcre-config'
("pkg-config" ,pkg-config)))
(inputs
`(("glib" ,glib)
@@ -94,7 +95,6 @@
("raptor2" ,raptor2)
("readline" ,readline)
("avahi" ,avahi)
- ("pcre" ,pcre)
("cyrus-sasl" ,cyrus-sasl)
("openssl" ,openssl)
("util-linux" ,util-linux)))
@@ -114,14 +114,14 @@ either single machines or networked clusters.")
(define-public gdbm
(package
(name "gdbm")
- (version "1.11")
+ (version "1.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gdbm/gdbm-"
version ".tar.gz"))
(sha256
(base32
- "1hz3jgh3pd4qzp6jy0l8pd8x01g9abw7csnrlnj1a2sxy122z4cd"))))
+ "1smwz4x5qa4js0zf1w3asq6z7mh20zlgwbh2bk5dczw6xrk22yyr"))))
(arguments `(#:configure-flags '("--enable-libgdbm-compat")))
(build-system gnu-build-system)
(home-page "http://www.gnu.org/software/gdbm/")
@@ -136,18 +136,20 @@ and provides interfaces to the traditional file format.")
(define-public bdb
(package
(name "bdb")
- (version "5.3.21")
+ (version "6.2.23")
(source (origin
(method url-fetch)
- (uri (string-append "http://download.oracle.com/berkeley-db/db-" version
- ".tar.gz"))
- (sha256 (base32
- "1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
+ (uri (string-append "http://download.oracle.com/berkeley-db/db-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1isxx4jfmnh913jzhp8hhfngbk6dsg46f4kjpvvc56maj64jqqa7"))))
(build-system gnu-build-system)
(outputs '("out" ; programs, libraries, headers
"doc")) ; 94 MiB of HTML docs
(arguments
'(#:tests? #f ; no check target available
+ #:disallowed-references ("doc")
#:phases
(alist-replace
'configure
@@ -165,6 +167,9 @@ and provides interfaces to the traditional file format.")
(string-append "CONFIG_SHELL=" (which "bash"))
(string-append "SHELL=" (which "bash"))
+ ;; Remove 7 MiB of .a files.
+ "--disable-static"
+
;; The compatibility mode is needed by some packages,
;; notably iproute2.
"--enable-compat185"
@@ -183,6 +188,18 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(home-page
"http://www.oracle.com/us/products/database/berkeley-db/overview/index.html")))
+(define-public bdb-5.3
+ (package (inherit bdb)
+ (name "bdb")
+ (version "5.3.28")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.oracle.com/berkeley-db/db-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0a1n5hbl7027fbz5lm0vp0zzfp1hmxnz14wx3zl9563h83br5ag0"))))))
+
(define-public mysql
(package
(name "mysql")
@@ -464,7 +481,7 @@ for example from a shell script.")
(define-public sqlite
(package
(name "sqlite")
- (version "3.10.0")
+ (version "3.12.2")
(source (origin
(method url-fetch)
;; TODO: Download from sqlite.org once this bug :
@@ -495,7 +512,7 @@ for example from a shell script.")
))
(sha256
(base32
- "0hhhv6si0pyf5i8bv7a71953m0b4gk6s3j2h09caf7vif0njkk23"))))
+ "1fwss0i2lixv39b27gkqiibdd2syym90wh3qbiaxnfgxk867f07x"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
(arguments