summaryrefslogtreecommitdiff
path: root/gnu/packages/django.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/django.scm')
-rw-r--r--gnu/packages/django.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 4f3e4914fa..3864cc884b 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -62,7 +62,7 @@
(zero? (system* "python" "tests/runtests.py")))))))
;; TODO: Install extras/django_bash_completion.
(native-inputs
- `(("tzdata", tzdata)
+ `(("tzdata", tzdata-for-tests)
;; bcrypt and argon2-cffi are extra requirements not yet in guix
;;("python-argon2-cffi" ,python-argon2-cffi) ; >= 16.1.0
;;("python-bcrypt" ,python-bcrypt) ; not py-bcrypt!
@@ -155,7 +155,7 @@ with arguments to the field constructor.")
`(("python-django" ,python-django)
("python-setuptools-scm" ,python-setuptools-scm)))
(propagated-inputs
- `(("python-pytest" ,python-pytest-3.0)))
+ `(("python-pytest" ,python-pytest)))
(home-page "http://pytest-django.readthedocs.org/")
(synopsis "Django plugin for py.test")
(description "Pytest-django is a plugin for py.test that provides a set of
@@ -707,7 +707,7 @@ static files.")
("stemming" ,python2-stemming)
("translate-toolkit" ,python2-translate-toolkit)))
(native-inputs
- `(("python2-pytest-warnings" ,python2-pytest-warnings)
+ `(("python2-pytest" ,python2-pytest)
("python2-pytest-django" ,python2-pytest-django)
("python2-pytest-catchlog" ,python2-pytest-catchlog)
("python2-pytest-cov" ,python2-pytest-cov)