summaryrefslogtreecommitdiff
path: root/gnu/packages/docbook.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/docbook.scm')
-rw-r--r--gnu/packages/docbook.scm44
1 files changed, 25 insertions, 19 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 9f2869ed25..30d360e81f 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -155,7 +155,8 @@ by no means limited to these applications.) This package provides XML DTDs.")
"18hgwvmywh6a5jh38szjmg3hg2r4v5lb6r3ydc3rd8cp9wg61i5c"))))))
(define-public docbook-xml-4.1.2
- (package (inherit docbook-xml)
+ (package
+ (inherit docbook-xml)
(version "4.1.2")
(source (origin
(method url-fetch)
@@ -169,13 +170,22 @@ by no means limited to these applications.) This package provides XML DTDs.")
#:builder
(begin
(use-modules (guix build utils))
- (let ((source (assoc-ref %build-inputs "source"))
- (unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip"))
- (dtd (string-append (assoc-ref %outputs "out")
- "/xml/dtd/docbook")))
+ (let* ((source (assoc-ref %build-inputs "source"))
+ (unzip (string-append (assoc-ref %build-inputs "unzip")
+ "/bin/unzip"))
+ (xmlcatalog (string-append (assoc-ref %build-inputs "libxml2")
+ "/bin/xmlcatalog"))
+ (dtd (string-append (assoc-ref %outputs "out")
+ "/xml/dtd/docbook"))
+ (catalog.xml (string-append dtd "/catalog.xml")))
(mkdir-p dtd)
- (invoke unzip source "-d" dtd)))))))
+ (invoke unzip source "-d" dtd)
+ ;; Create a minimal XML catalog, to use with libxml2 tools.
+ (invoke xmlcatalog "--noout" "--create" catalog.xml)
+ (invoke xmlcatalog "--noout" "--add" "public"
+ "-//OASIS//DTD DocBook XML V4.1.2//EN"
+ (string-append dtd "/docbookx.dtd") catalog.xml)))))
+ (native-inputs (list libxml2 unzip))))
(define-public docbook-xsl
(package
@@ -581,29 +591,25 @@ the in DocBook SGML DTDs.")
texlive-latex-changebar
texlive-latex-colortbl
texlive-latex-fancybox
- texlive-latex-fancyhdr
- texlive-latex-fancyvrb
+ texlive-fancyhdr
+ texlive-fancyvrb
texlive-latex-float
texlive-latex-footmisc
texlive-hyperref
texlive-latex-jknapltx
-
- ;; TODO: Use non-deprecated name on
- ;; next rebuild cycle.
- texlive-latex-listings
-
+ texlive-listings
texlive-latex-multirow
texlive-latex-overpic
- texlive-latex-pdfpages
- texlive-latex-refcount
- texlive-latex-subfigure
- texlive-latex-titlesec
+ texlive-pdfpages
+ texlive-refcount
+ texlive-subfigure
+ texlive-titlesec
texlive-wasysym
texlive-fonts-rsfs
texlive-stmaryrd
- texlive-generic-iftex)))
+ texlive-iftex)))
("imagemagick" ,imagemagick) ;for convert
("inkscape" ,inkscape/stable) ;for svg conversion
("docbook" ,docbook-xml)