summaryrefslogtreecommitdiff
path: root/gnu/packages/documentation.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/documentation.scm')
-rw-r--r--gnu/packages/documentation.scm88
1 files changed, 43 insertions, 45 deletions
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index a372e1a6ca..bbaa01e392 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.counoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -140,8 +140,7 @@ pages in HTML.")
(("XMLLINT = 'xmllint'")
(string-append "XMLLINT = '" xmllint "'"))
(("XSLTPROC = 'xsltproc'")
- (string-append "XSLTPROC = '" xsltproc "'")))
- #t)))
+ (string-append "XSLTPROC = '" xsltproc "'"))))))
;; Make asciidoc use the local docbook-xsl package instead of fetching
;; it from the internet at run-time.
(add-before 'install 'make-local-docbook-xsl
@@ -153,20 +152,16 @@ release/xsl/current")
"xsl:import href=\""
(string-append (assoc-ref inputs "docbook-xsl")
"/xml/xsl/docbook-xsl-"
- ,(package-version docbook-xsl)))))
- #t))
+ ,(package-version docbook-xsl)))))))
;; Do the same for docbook-xml.
(add-before 'install 'make-local-docbook-xml
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "docbook45.conf"
(("http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd")
(string-append (assoc-ref inputs "docbook-xml")
- "/xml/dtd/docbook/docbookx.dtd")))
- #t)))))
- (native-inputs
- (list autoconf))
- (inputs
- (list python docbook-xml docbook-xsl libxml2 libxslt))
+ "/xml/dtd/docbook/docbookx.dtd"))))))))
+ (native-inputs (list autoconf))
+ (inputs (list python docbook-xml-4.5 docbook-xsl libxml2 libxslt))
(home-page "https://asciidoc.org/")
(synopsis "Text-based document generation system")
(description
@@ -185,48 +180,51 @@ markup) can be customized and extended by the user.")
(define-public doxygen
(package
(name "doxygen")
- (version "1.9.1")
+ (version "1.9.5")
(home-page "https://www.doxygen.nl/")
(source (origin
- (method url-fetch)
- (uri (list (string-append home-page "files/doxygen-"
- version ".src.tar.gz")
- (string-append "mirror://sourceforge/doxygen/rel-"
- version "/doxygen-" version
- ".src.tar.gz")))
- (sha256
- (base32
- "1lcif1qi20gf04qyjrx7x367669g17vz2ilgi4cmamp1whdsxbk7"))))
+ (method url-fetch)
+ (uri (list (string-append home-page "files/doxygen-"
+ version ".src.tar.gz")
+ (string-append "mirror://sourceforge/doxygen/rel-"
+ version "/doxygen-" version
+ ".src.tar.gz")))
+ (sha256
+ (base32
+ "1v1f9cp5lyymg7xmw0ldnzi7ql8agbaqam1xdyljk0lrbnrm9d2m"))))
(build-system cmake-build-system)
(native-inputs
- (list bison flex libxml2 ;provides xmllint for the tests
- python)) ;for creating the documentation
+ (list bison
+ flex
+ libxml2 ;provides xmllint for the tests
+ python)) ;for creating the documentation
(inputs
- `(("bash" ,bash-minimal)))
+ (list bash-minimal))
(arguments
;; Force cmake to use iconv header from cross-libc instead of the one
;; from native libc.
- `(,@(if (%current-target-system)
- '(#:configure-flags
- (list (string-append "-DICONV_INCLUDE_DIR="
- (assoc-ref %build-inputs "cross-libc")
- "/include")))
- '())
- #:test-target "tests"
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'disable-bibtex-test
- (lambda _
- ;; Disable test that requires bibtex to avoid a
- ;; circular dependency.
- (for-each delete-file-recursively
- '("testing/012" "testing/012_cite.dox"))))
- (add-before 'configure 'patch-sh
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/portable.cpp"
- (("/bin/sh")
- (string-append
- (assoc-ref inputs "bash") "/bin/sh")))
- #t)))))
+ (list
+ #:configure-flags
+ (if (%current-target-system)
+ #~(list (string-append "-DICONV_INCLUDE_DIR="
+ (assoc-ref %build-inputs "cross-libc")
+ "/include"))
+ #~'())
+ #:test-target "tests"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-bibtex-test
+ (lambda _
+ ;; Disable test that requires bibtex to avoid a
+ ;; circular dependency.
+ (for-each delete-file-recursively
+ '("testing/012" "testing/012_cite.dox"))))
+ (add-before 'configure 'patch-sh
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((/bin/sh (search-input-file inputs "/bin/sh")))
+ (substitute* "src/portable.cpp"
+ (("/bin/sh")
+ /bin/sh))))))))
(synopsis "Generate documentation from annotated sources")
(description "Doxygen is the de facto standard tool for generating
documentation from annotated C++ sources, but it also supports other popular