summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 66ac39b701..6485ec4f0f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27764,8 +27764,17 @@ turn.")
(native-inputs
(list emacs-buttercup emacs-undercover))
(arguments
- `(#:tests? #t
- #:test-command '("buttercup" "-L" "test/github-review-test.el")))
+ (list
+ #:tests? #t
+ #:test-command #~(list "buttercup" "-L" "test/github-review-test.el")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'compatibility-with-recent-buttercup
+ (lambda _
+ (emacs-batch-edit-file "test/github-review-test.el"
+ '(progn
+ (insert ";;; -*-lexical-binding:t-*-")
+ (basic-save-buffer))))))))
(home-page "https://github.com/charignon/github-review")
(synopsis "Review GitHub pull requests within Emacs")
(description "This package provides commands to pull in, comment on, and