summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm63
1 files changed, 55 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5f49c64bb7..907ff200e0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -85,6 +85,7 @@
;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
+;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10357,6 +10358,31 @@ Flx has support for ido (interactively do things) through flx-ido.")
known loosely as deftheme. Many mode-specific customizations are included.")
(license license:gpl3+)))
+(define-public emacs-dart-mode
+ (package
+ (name "emacs-dart-mode")
+ (version "1.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bradyt/dart-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qmdlwjmmqyyb65sqvfpygifai5m0llc815vp0jqwp8ldd8ls172"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-flycheck" ,emacs-flycheck)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/bradyt/dart-mode")
+ (synopsis "Emacs mode for the Dart programming language")
+ (description
+ "Dart mode is an Emacs major mode for editing Dart files. It provides
+basic syntax highlighting and indentation.")
+ (license license:gpl3+)))
+
(define-public emacs-danneskjold-theme
(let* ((commit "8733d2fe8743e8a01826ea6d4430ef376c727e57")
(revision "1"))
@@ -10602,6 +10628,28 @@ provides functions to convert hash tables from and to alists and plists.")
you to deal with multiple log levels.")
(license license:gpl3+)))
+(define-public emacs-gn-mode
+ (package
+ (name "emacs-gn-mode")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lashtear/gn-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dz5kgzbgsssr38z2kg6m915cvfys42ag1k42bsra3la2pixywfx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/lashtear/gn-mode")
+ (synopsis "Emacs major mode for editing GN (ninja generator) config files")
+ (description
+ "GN mode is a major mode for editing @acronym{GN,Ninja Generator} config
+files in Emacs. Files of this type (e.g., @file{BUILD.gn} or @file{*.gni})
+are common in Chromium-derived projects.")
+ (license license:bsd-3)))
+
(define-public emacs-gntp
(package
(name "emacs-gntp")
@@ -14111,15 +14159,14 @@ Anzu.zim.")
(define-public emacs-ascii-art-to-unicode
(package
(name "emacs-ascii-art-to-unicode")
- (version "1.12")
+ (version "1.13")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/ascii-art-to-unicode-"
version ".el"))
(sha256
- (base32
- "1w9h2lyriafxj71r79774gh822cz8mry3gdfzyj6ym6v9mvqypna"))))
+ (base32 "1c0jva3amhl9c5xc5yzdpi58c8m1djym4ccj31z6wmakq7npy07p"))))
(build-system emacs-build-system)
(home-page "https://elpa.gnu.org/packages/ascii-art-to-unicode.html")
(synopsis "ASCII to Unicode art converter for Emacs")
@@ -19796,7 +19843,7 @@ too ambiguous and navigation in the result buffer.")
(home-page "https://github.com/sebastiencs/frame-local")
(synopsis "Access variables local to an Emacs frame")
(description
- "This packages allows setting and accessing variables local to
+ "This package allows setting and accessing variables local to
an Emacs frame. Note that the variables created with this package do
not have any relation with variables defined by @code{defvar},
@code{defconst}, etc.")
@@ -22299,7 +22346,7 @@ and article extracts for Wikipedia.")
(define-public emacs-webfeeder
(package
(name "emacs-webfeeder")
- (version "1.1.0")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
@@ -22309,7 +22356,7 @@ and article extracts for Wikipedia.")
".tar"))
(sha256
(base32
- "09wz6v58xc86hdnz6g54ckaxkm6844yyk2ffbxh4s5sdvgqrzdd8"))))
+ "09caj12hfdfhlbcsmjyhw728w1f7yq13hdslh793yvfqv83ipvc4"))))
(build-system emacs-build-system)
(home-page "https://gitlab.com/Ambrevar/emacs-webfeeder")
(synopsis "Build RSS and Atom webfeeds from HTML files")
@@ -23955,14 +24002,14 @@ interface.")
(define-public emacs-ivy-posframe
(package
(name "emacs-ivy-posframe")
- (version "0.5.2")
+ (version "0.5.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"ivy-posframe-" version ".el"))
(sha256
- (base32 "01zc2yj7g4lfz7qblx7k6sg54v0h4w0frnnmsf92lwypfijd2lsj"))))
+ (base32 "03ydfb155p5lak7nw4s79ab9zadwsjw1zggzwxgnlydsqdqbr6l6"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-ivy" ,emacs-ivy)