summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm522
1 files changed, 361 insertions, 161 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d02e1dc7d5..ff2ed00c47 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -114,6 +114,7 @@
;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;; Copyright © 2022 Haider Mirza <haider@haider.gq>
+;;; Copyright © 2022 Jose G Perez Taveras <josegpt27@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -778,10 +779,10 @@ information in the mode line.")
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/project-" version ".tar"))
(sha256
- (base32 "1x3zkbjsi04v5ny3yxqrb75vcacrj9kxmpm9mvkp0n07j5g34f68"))))
+ (base32 "0q2js8qihlhchpx2mx0f992ygslsqri2q4iv8kcl4fx31lpp7c1k"))))
(build-system emacs-build-system)
(propagated-inputs (list emacs-xref))
- (home-page "http://elpa.gnu.org/packages/project.html")
+ (home-page "https://elpa.gnu.org/packages/project.html")
(synopsis "Operations on the current project")
(description
"This library contains generic infrastructure for dealing with projects,
@@ -1627,92 +1628,99 @@ replacement.")
(license license:gpl3+))))
(define-public emacs-haskell-mode
- (package
- (name "emacs-haskell-mode")
- (version "17.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/haskell/haskell-mode")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0zxbacqzr84krmhqpvzndnvlcjh1gs1x20ys0dykgd7chyhci5j5"))))
- (propagated-inputs
- (list emacs-dash))
- (native-inputs
- (list emacs-minimal emacs-el-search emacs-stream texinfo))
- (build-system gnu-build-system)
- (arguments
- (list
- #:make-flags #~(list
- (string-append "EMACS=" #$emacs-minimal "/bin/emacs"))
- #:modules `((ice-9 match)
- (srfi srfi-26)
- ((guix build emacs-build-system) #:prefix emacs:)
- ,@%gnu-build-system-modules)
- #:imported-modules `(,@%gnu-build-system-modules
- (guix build emacs-build-system)
- (guix build emacs-utils))
- #:phases
- #~(modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'pre-build
- (lambda* (#:key inputs #:allow-other-keys)
- (define (el-dir store-dir)
- (match (find-files store-dir "\\.el$")
- ((f1 f2 ...) (dirname f1))
- (_ "")))
-
- (let ((sh (search-input-file inputs "/bin/sh")))
- (define emacs-prefix? (cut string-prefix? "emacs-" <>))
-
- (setenv "SHELL" "sh")
- (setenv "EMACSLOADPATH"
- (string-concatenate
- (map (match-lambda
- (((? emacs-prefix? name) . dir)
- (string-append (el-dir dir) ":"))
- (_ ""))
- inputs)))
- (substitute* (find-files "." "\\.el") (("/bin/sh") sh)))))
- (add-before 'check 'delete-failing-tests
- ;; XXX: these tests require GHC executable, which would be a big
- ;; native input.
- (lambda _
- (with-directory-excursion "tests"
- ;; File `haskell-indent-tests.el' fails with
- ;; `haskell-indent-put-region-in-literate-2'
- ;; on Emacs 27.1+
- ;; XXX: https://github.com/haskell/haskell-mode/issues/1714
- (for-each delete-file
- '("haskell-indent-tests.el"
- "haskell-customize-tests.el"
- "inferior-haskell-tests.el")))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (el-dir (emacs:elpa-directory out))
- (doc (string-append
- out "/share/doc/haskell-mode-" #$version))
- (info (string-append out "/share/info")))
- (define (copy-to-dir dir files)
- (for-each (lambda (f)
- (install-file f dir))
- files))
-
- (with-directory-excursion "doc"
- (invoke "makeinfo" "haskell-mode.texi")
- (install-file "haskell-mode.info" info))
- (copy-to-dir doc '("CONTRIBUTING.md" "NEWS" "README.md"))
- (copy-to-dir el-dir (find-files "." "\\.elc?"))))))))
- (home-page "https://github.com/haskell/haskell-mode")
- (synopsis "Haskell mode for Emacs")
- (description
- "This is an Emacs mode for editing, debugging and developing Haskell
+ (let ((revision "0")
+ (commit "5a9f8072c7b9168f0a8409adf9d62a3e4ad4ea3d"))
+ (package
+ (name "emacs-haskell-mode")
+ (version (git-version "17.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/haskell/haskell-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0np1wrwdq7b9hpqpl9liampacnkx6diphyk8h2sbz2mfn9qr7pxs"))))
+ (propagated-inputs
+ (list emacs-dash))
+ (native-inputs
+ (list emacs-minimal emacs-el-search emacs-stream texinfo))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags #~(list
+ (string-append "EMACS=" #$emacs-minimal "/bin/emacs"))
+ #:modules `((ice-9 match)
+ (srfi srfi-26)
+ ((guix build emacs-build-system) #:prefix emacs:)
+ ,@%gnu-build-system-modules)
+ #:imported-modules `(,@%gnu-build-system-modules
+ (guix build emacs-build-system)
+ (guix build emacs-utils))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'pre-build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define (el-dir store-dir)
+ (match (find-files store-dir "\\.el$")
+ ((f1 f2 ...) (dirname f1))
+ (_ "")))
+
+ (let ((sh (search-input-file inputs "/bin/sh")))
+ (define emacs-prefix? (cut string-prefix? "emacs-" <>))
+
+ (setenv "SHELL" "sh")
+ (setenv "EMACSLOADPATH"
+ (string-concatenate
+ (map (match-lambda
+ (((? emacs-prefix? name) . dir)
+ (string-append (el-dir dir) ":"))
+ (_ ""))
+ inputs)))
+ (substitute* (find-files "." "\\.el") (("/bin/sh") sh)))))
+ (add-before 'check 'delete-failing-tests
+ ;; XXX: these tests require GHC executable, which would be a big
+ ;; native input.
+ (lambda _
+ (with-directory-excursion "tests"
+ ;; File `haskell-indent-tests.el' fails with
+ ;; `haskell-indent-put-region-in-literate-2'
+ ;; on Emacs 27.1+
+ ;; XXX: https://github.com/haskell/haskell-mode/issues/1714
+ (for-each delete-file
+ '("haskell-indent-tests.el"
+ "haskell-customize-tests.el"
+ "inferior-haskell-tests.el"))
+
+ ;; requires many external tools (e.g. git, hasktags)
+ (substitute* "haskell-mode-tests.el"
+ (("\\(ert-deftest haskell-generate-tags.*" all)
+ (string-append all " (skip-unless nil)"))))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (el-dir (emacs:elpa-directory out))
+ (doc (string-append
+ out "/share/doc/haskell-mode-" #$version))
+ (info (string-append out "/share/info")))
+ (define (copy-to-dir dir files)
+ (for-each (lambda (f)
+ (install-file f dir))
+ files))
+
+ (with-directory-excursion "doc"
+ (invoke "makeinfo" "haskell-mode.texi")
+ (install-file "haskell-mode.info" info))
+ (copy-to-dir doc '("CONTRIBUTING.md" "NEWS" "README.md"))
+ (copy-to-dir el-dir (find-files "." "\\.elc?"))))))))
+ (home-page "https://github.com/haskell/haskell-mode")
+ (synopsis "Haskell mode for Emacs")
+ (description
+ "This is an Emacs mode for editing, debugging and developing Haskell
programs.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-dante
(let ((commit "38b589417294c7ea44bf65b73b8046d950f9531b")
@@ -1746,47 +1754,44 @@ supports type hints, definition-jumping, completion, and more.")
(license license:gpl3+))))
(define-public emacs-flycheck
- ;; Last release version was more than 500 commits ago.
- (let ((commit "9bcf6b665e15db94870bebc81dc8248c3eec20d3")
- (revision "2"))
- (package
- (name "emacs-flycheck")
- (version (git-version "31" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/flycheck/flycheck/")
- (commit commit)))
- (sha256
- (base32 "015ixss5bjr7gvhj8mkw5x2x1hy6fvvsjarr2xpv0gskkkngs7pg"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-dash))
- (native-inputs
- (list emacs-shut-up))
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'change-flycheck-version
- (lambda _
- (substitute* "flycheck.el"
- (("\\(pkg-info-version-info 'flycheck\\)")
- (string-append "\"" #$version "\""))))))
- ;; TODO: many failing tests
- #:tests? #f
- #:test-command
- #~(list "emacs" "-Q" "--batch"
- "-L" "."
- "--load" "test/flycheck-test"
- "--load" "test/run.el"
- "-f" "flycheck-run-tests-main")))
- (home-page "https://www.flycheck.org")
- (synopsis "On-the-fly syntax checking")
- (description
- "This package provides on-the-fly syntax checking for GNU Emacs. It is a
+ (package
+ (name "emacs-flycheck")
+ (version "32")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flycheck/flycheck/")
+ (commit version)))
+ (sha256
+ (base32 "0dx6wqxz1yfp4shas4yn6abqc8bz21ks3glcyzznm3xspjdaq21s"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-dash))
+ (native-inputs
+ (list emacs-shut-up))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'change-flycheck-version
+ (lambda _
+ (substitute* "flycheck.el"
+ (("\\(pkg-info-version-info 'flycheck\\)")
+ (string-append "\"" #$version "\""))))))
+ ;; TODO: many failing tests
+ #:tests? #f
+ #:test-command
+ #~(list "emacs" "-Q" "--batch"
+ "-L" "."
+ "--load" "test/flycheck-test"
+ "--load" "test/run.el"
+ "-f" "flycheck-run-tests-main")))
+ (home-page "https://www.flycheck.org")
+ (synopsis "On-the-fly syntax checking")
+ (description
+ "This package provides on-the-fly syntax checking for GNU Emacs. It is a
replacement for the older Flymake extension which is part of GNU Emacs, with
many improvements and additional features.
@@ -1794,7 +1799,7 @@ Flycheck provides fully-automatic, fail-safe, on-the-fly background syntax
checking for over 30 programming and markup languages with more than 70
different tools. It highlights errors and warnings inline in the buffer, and
provides an optional IDE-like error list.")
- (license license:gpl3+)))) ;+GFDLv1.3+ for the manual
+ (license license:gpl3+))) ;+GFDLv1.3+ for the manual
(define-public emacs-flymake-flycheck
(package
@@ -2571,14 +2576,14 @@ directories or regex patterns.")
(define-public emacs-bbdb
(package
(name "emacs-bbdb")
- (version "3.2.1")
+ (version "3.2.2.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"bbdb-" version ".tar"))
(sha256
- (base32 "01vsnifs47krq1srgdkk9agbv3p2fykl9nydr4nrfjxbqpnyh3ij"))))
+ (base32 "0bf20r5xhxln6z4qp8zrlln0303dkci2ydsr74pxcj08aqgk5xxf"))))
(build-system emacs-build-system)
(arguments
;; XXX: The following file cannot be byte-compiled, because et requires
@@ -2897,14 +2902,14 @@ as a library for other Emacs packages.")
(define-public emacs-auctex
(package
(name "emacs-auctex")
- (version "13.1.1")
+ (version "13.1.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"auctex-" version ".tar"))
(sha256
- (base32 "193sqq2wiq3lg99m8hifl9rjxdazpy638r99sqvmxmkfm98cr34r"))))
+ (base32 "0v9rxwz6ngnwrgvzgdki861s136gq30lqhy2gcd9q0a36gb6zhwk"))))
(build-system emacs-build-system)
;; We use 'emacs' because AUCTeX requires dbus at compile time
;; ('emacs-minimal' does not provide dbus).
@@ -6778,6 +6783,37 @@ tupfiles, such as rule definitions, user-defined variables, macros, flags, bin
variables, and so on. The mode also allows you to execute Tup commands.")
(license license:gpl3+)))
+(define-public emacs-compat
+ (package
+ (name "emacs-compat")
+ (version "28.1.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~pkal/compat")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19abp29rnbkw91q0h2yqm2z7awzzjhci8h6v875g5ahvplrp6337"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-nadvice))
+ (home-page "https://git.sr.ht/~pkal/compat")
+ (synopsis "Emacs Lisp Compatibility Library")
+ (description
+ "To allow for the usage of Emacs functions and macros that are defined
+in newer versions of Emacs, @code{compat.el} provides definitions that
+are installed ONLY if necessary. These reimplementations of functions
+and macros are at least subsets of the actual implementations. Be
+sure to read the documentation string to make sure.
+
+Not every function provided in newer versions of Emacs is provided
+here. Some depend on new features from the core, others cannot be
+implemented to a meaningful degree. The main audience for this
+library are not regular users, but package maintainers. Therefore
+commands and user options are usually not implemented here.")
+ (license license:gpl3+)))
+
(define-public emacs-company
(package
(name "emacs-company")
@@ -7797,8 +7833,39 @@ using @code{python-isort}.")
(base32
"1bckxppfzd5gwn0aw4h86igb7igal9axqncq7j8zmflg7zppncf1"))))
(build-system emacs-build-system)
- (native-inputs
- (list emacs-mocker))
+ (arguments
+ (list
+ #:imported-modules `(,@%emacs-build-system-modules
+ (guix build python-build-system))
+ #:modules '((guix build emacs-build-system)
+ ((guix build python-build-system) #:prefix python:)
+ (guix build emacs-utils)
+ (guix build utils))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'ensure-no-mtimes-pre-1980
+ (assoc-ref python:%standard-phases
+ 'ensure-no-mtimes-pre-1980))
+ (add-after 'ensure-no-mtimes-pre-1980 'relax-python-requirements
+ (lambda _
+ ;; Argparse should only be required for Python < 3.2
+ ;; (see: https://github.com/tkf/emacs-jedi/issues/365).
+ (substitute* "setup.py"
+ ((".*argparse.*") ""))))
+ (add-after 'relax-python-requirements 'python:add-install-to-pythonpath
+ (assoc-ref python:%standard-phases 'add-install-to-pythonpath))
+ (add-after 'python:add-install-to-pythonpath 'python:install
+ ;; This is needed to get the Python-built 'jediepcserver' command.
+ (assoc-ref python:%standard-phases 'install))
+ (add-after 'python:install 'python:wrap
+ (assoc-ref python:%standard-phases 'wrap))
+ (add-after 'python:wrap 'patch-jedi:server-command
+ (lambda* (#:key outputs #:allow-other-keys)
+ (emacs-substitute-variables "jedi-core.el"
+ ("jedi:server-command"
+ (search-input-file outputs "bin/jediepcserver"))))))))
+ (native-inputs (list emacs-mocker python-wrapper))
+ (inputs (list python-wrapper python-epc python-jedi)) ;wrapped
(propagated-inputs
(list emacs-auto-complete emacs-python-environment emacs-epc))
(home-page "https://github.com/tkf/emacs-jedi")
@@ -8499,7 +8566,7 @@ variants.")
(define-public emacs-solarized-theme
(package
(name "emacs-solarized-theme")
- (version "1.3.1")
+ (version "2.0.0")
(source
(origin
(method git-fetch)
@@ -8508,7 +8575,7 @@ variants.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "15ql8xcixgm7mbs7rsbybwszanqibq057j5b5ds89a31dw7zxf1g"))))
+ (base32 "17z6cj8ids88xj2i6zs1s0mxs0fhn3gr7g5nhhy8s8khnzmyy2vj"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-dash))
@@ -8834,7 +8901,7 @@ them easier to distinguish from other, less important buffers.")
(define-public emacs-embark
(package
(name "emacs-embark")
- (version "0.16")
+ (version "0.17")
(source
(origin
(method git-fetch)
@@ -8842,7 +8909,7 @@ them easier to distinguish from other, less important buffers.")
(url "https://github.com/oantolin/embark")
(commit version)))
(sha256
- (base32 "04xxwhh577aam0fqfmprxqaw0v1l6yidikr6chajcf16mf1wd2gv"))
+ (base32 "1s0ssf4q9kg4c5w87h2ypyvrhi31mz3s6k4h7pxi9a47lkccq8n1"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(propagated-inputs
@@ -8952,7 +9019,7 @@ style, or as multiple word prefixes.")
(define-public emacs-consult
(package
(name "emacs-consult")
- (version "0.17")
+ (version "0.18")
(source
(origin
(method git-fetch)
@@ -8960,9 +9027,10 @@ style, or as multiple word prefixes.")
(url "https://github.com/minad/consult")
(commit version)))
(sha256
- (base32 "08l3h7b5j1q9nwcq660667b245qspl20ikhfdvd9k3g3n2p6p5kz"))
+ (base32 "0sy4rn1vjk1g50r8z14hzj8lds6s7ij2zkjqfi6mfash5il75wnq"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
(home-page "https://github.com/minad/consult")
(synopsis "Consulting completing-read")
(description "This package provides various handy commands based on the
@@ -9018,6 +9086,27 @@ replaced with the directory you choose.")
and present results either as single emails or full trees.")
(license license:gpl3+)))
+(define-public emacs-consult-eglot
+ (package
+ (name "emacs-consult-eglot")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mohkale/consult-eglot")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1qxk1npxbf8m3g9spikgdxcf6mzjx6cwy3f5vn6zz5ksh14xw3sd"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-consult emacs-eglot))
+ (home-page "https://github.com/mohkale/consult-eglot")
+ (synopsis "Consulting-read interface for eglot")
+ (description "This package acts as a parallel of consult-lsp for eglot and
+provides a front-end interface for the workspace/symbols LSP procedure
+call.")
+ (license license:gpl3+)))
+
(define-public emacs-marginalia
(package
(name "emacs-marginalia")
@@ -9071,6 +9160,35 @@ features found in other packages it also brings many improvements as
well as completely new features.")
(license license:gpl3+)))
+(define-public emacs-dumbparens
+ ;; There are no releases.
+ (let ((commit "18b668772f25e5f7b62c0a000b8169eaf7515057")
+ (revision "0"))
+ (package
+ (name "emacs-dumbparens")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/raxod502/dumbparens")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xv2yzjzq2450z007jppf86knnwzb2s3sxvqyk1yp6qs9mgrmnyp"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command #~(list "make" "test")))
+ (home-page "https://github.com/raxod502/dumbparens/")
+ (synopsis "Minor mode that provides improvements on Smartparens")
+ (description
+ "@code{emacs-dumbparens} is a minor mode for Emacs that deals with parens
+pairs and doesn't try to be smart about it.")
+ (license license:expat))))
+
(define-public emacs-highlight-symbol
;; We prefer a more recent commit that provides an option to squelch
;; echo-area alerts that can drown out useful information like eldoc
@@ -9982,8 +10100,9 @@ state and will work even without lispy being enabled.")
(license license:gpl3+))))
(define-public emacs-lpy
- (let ((commit "43b401fe15f0f0d01edb189378b9498121e9f766")
- (revision "3"))
+ ;; There is no proper release/tag.
+ (let ((commit "076ce9acb68f6ac1b39127b634a91ffd865d13d8")
+ (revision "4"))
(package
(name "emacs-lpy")
(version (git-version "0.1.0" revision commit))
@@ -9995,7 +10114,7 @@ state and will work even without lispy being enabled.")
(commit commit)))
(sha256
(base32
- "0xj1r7cn1rivaxhvawvmgx9fg3xilpfw4lkf2x2aqplr4s85ijas"))
+ "10sab50wmr3zn7jgzx93201ymhmacqacn3m2qllsqkfw2gpsi6dn"))
(file-name (git-file-name name version))))
(propagated-inputs
(list emacs-zoutline emacs-lispy))
@@ -11575,7 +11694,7 @@ Emacs.")
(define-public emacs-web-mode
(package
(name "emacs-web-mode")
- (version "17")
+ (version "17.2.1")
(source
(origin
(method git-fetch)
@@ -11584,7 +11703,7 @@ Emacs.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0jr5a1nzp8nbdng0k2fcaymiiv9ngrbknbrqaswgqn3akvx793jk"))))
+ (base32 "0sd2ysysn8x4iwz2fhnvh8knr3pdqgkvhkhsl948smmfl0dwj42f"))))
(build-system emacs-build-system)
(synopsis "Major mode for editing web templates")
(description "Web mode is an Emacs major mode for editing web templates
@@ -16006,8 +16125,8 @@ which avoids some of the issues with using Emacs’s built-in Url library.")
(license license:gpl3+)))
(define-public emacs-ement
- (let ((commit "c951737dc855604aba389166bb0e7366afadc533")
- (revision "1"))
+ (let ((commit "45b7882c8a8f28eb59113f78db0e79918f2c58ee")
+ (revision "2"))
(package
(name "emacs-ement")
(version (git-version "0.1-pre" revision commit))
@@ -16019,12 +16138,15 @@ which avoids some of the issues with using Emacs’s built-in Url library.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "00iwwz4hzg4g59wrb5df6snqz3ppvrsadhfp61w1pa8gvg2z9bvy"))))
+ (base32 "1f79h9l7chazan7kh2g73banqim5p4gz2nyx3cvp9jjfz32c4k46"))))
(build-system emacs-build-system)
(arguments
`(#:emacs ,emacs)) ;need libxml support
(propagated-inputs
- (list emacs-plz emacs-ts))
+ (list emacs-plz
+ emacs-svg-lib
+ emacs-taxy
+ emacs-ts))
(home-page "https://github.com/alphapapa/ement.el")
(synopsis "Matrix client for Emacs")
(description "Ement.el is a Matrix client for Emacs.")
@@ -16359,8 +16481,8 @@ key. Optionally, a mouse pop-up can be added by binding
(license license:gpl3+)))
(define-public emacs-idris-mode
- (let ((commit "b77eadd8ac2048d5c882b4464bd9673e45dd6a59")
- (revision "0"))
+ (let ((commit "9bc7697406f719258d93835df3c1761efbfecaa7")
+ (revision "1"))
(package
(name "emacs-idris-mode")
(version (git-version "1.0" revision commit))
@@ -16373,7 +16495,7 @@ key. Optionally, a mouse pop-up can be added by binding
(file-name (git-file-name name commit))
(sha256
(base32
- "1v8av6jza1j00ln75zjwaca0vmmv0fhhhi94p84rlfzgzykyb9g1"))))
+ "1d1f7kx0fw632js7qd1sra5wbpwyamcqs5wpzhyynmr5ybb0vyl7"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-prop-menu))
@@ -26600,14 +26722,14 @@ well as an option for visually flashing evaluated s-expressions.")
(define-public emacs-tramp
(package
(name "emacs-tramp")
- (version "2.5.2.2")
+ (version "2.5.2.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"tramp-" version ".tar"))
(sha256
- (base32 "104nn6xdmcviqqv4cx5llhwj1sh4q04w3h9s8gimmi2kg0z8s36r"))))
+ (base32 "05f59x7jl4m187y2cidhnfz7p8q85gav4xpipazfvm5dicxz4j7c"))))
(build-system emacs-build-system)
(arguments
(list
@@ -27248,7 +27370,7 @@ it forcibly
(define-public emacs-elpher
(package
(name "emacs-elpher")
- (version "3.3.3")
+ (version "3.4.1")
(source
(origin
(method git-fetch)
@@ -27257,7 +27379,7 @@ it forcibly
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "166fjq9d883hifa35zklyjrm4c575nd6zxdx7akbwibrgwi65bl0"))))
+ (base32 "0dv71zc95m5sa4824vk3d1xk726nh2v50i0yp6w3ydfzzsfph6j6"))))
(build-system emacs-build-system)
(arguments
(list
@@ -31029,7 +31151,7 @@ and preferred services can easily be configured.")
(define-public emacs-vertico
(package
(name "emacs-vertico")
- (version "0.23")
+ (version "0.24")
(source
(origin
(method git-fetch)
@@ -31038,7 +31160,7 @@ and preferred services can easily be configured.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1lyvnpqplwdawlplriz0rphsjsaqdcbc3nwzpd7bs9qghpsfb56z"))))
+ (base32 "03p9rf80jnralxpydvxi88igs0r6qa6v41xf1fafwgsf235b49yi"))))
(build-system emacs-build-system)
(arguments
`(#:phases
@@ -31205,6 +31327,30 @@ to the @url{https://multitran.com} online dictionary.")
@command{python} buffers.")
(license license:gpl3)))
+(define-public emacs-code-cells
+ ;; No tagged release upstream
+ (let ((commit "8660bdeedee360e5eb632f1eb1356eb09d7dfbee")
+ (revision "0"))
+ (package
+ (name "emacs-code-cells")
+ (version (git-version "0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/astoff/code-cells.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mvfsdlhc3znc0d2p8vm7apkbpvbs688wmwvd0sms33qly53f546"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/astoff/code-cells.el")
+ (synopsis "Emacs utilities for code split into cells, including Jupyter
+notebooks")
+ (description "This package lets you efficiently navigate, edit and
+execute code split into cells according to certain magic comments.")
+ (license license:gpl3+))))
+
(define-public emacs-kibit-helper
(package
(name "emacs-kibit-helper")
@@ -31398,14 +31544,14 @@ are prefixed with @code{seq-} and work on lists, strings, and vectors.")
(define-public emacs-setup
(package
(name "emacs-setup")
- (version "1.2.0")
+ (version "1.3.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/setup-"
version ".tar"))
(sha256
- (base32 "1fyzkm42gsvsjpk3vahfb7asfldarixm0wsw3g66q3ad0r7cbjnz"))))
+ (base32 "0r13ry73jm31j8fq7v1sh0k113fr4blfkiz85696bdpah2pnca87"))))
(build-system emacs-build-system)
(home-page "https://git.sr.ht/~pkal/setup")
(synopsis "Helpful configuration macro")
@@ -31565,6 +31711,60 @@ headlines, keywords, tables and source blocks.")
"@code{emacs-pyimport} manages python imports from Emacs via @code{python-pyflakes}.")
(license license:gpl3+)))) ; License is in pyimport.el
+(define-public emacs-straight-el
+ (let ((commit "4517e118ee43f849f708025dbb2cf4f281793121")
+ (revision "0"))
+ (package
+ (name "emacs-straight-el")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/raxod502/straight.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0idhgh203rac9c046286gir9rq0lgnlllzj4b4hrjpd3idg9v0r8"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command
+ #~(list "emacs" "-Q" "--batch"
+ "-L" "."
+ "--load" "ert"
+ "--load" "tests/straight-test.el"
+ "--eval" "(progn (require 'straight-ert-print-hack) (ert-run-tests-batch-and-exit))")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-git-executable
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "straight.el")
+ (substitute* "straight.el"
+ (("\"git\"")
+ (string-append "\""
+ (search-input-file inputs "/bin/git")
+ "\"")))))
+ (add-after 'check 'delete-tests
+ ;; "tests" directory includes bogus ".el" files that can make
+ ;; `patch-el-files' phase fail.
+ (lambda _
+ (delete-file-recursively "tests"))))))
+ (native-inputs
+ (list texinfo))
+ (inputs
+ (list git))
+ (propagated-inputs
+ (list emacs-magit))
+ (home-page "https://github.com/raxod502/straight.el/")
+ (synopsis "Purely functional package manager for the Emacs hacker")
+ (description
+ "@code{emacs-straight-el} is a purely functional package manager for the Emacs
+hacker.")
+ (license license:expat))))
+
(define-public emacs-osm
(package
(name "emacs-osm")