summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7fa5df9202..24399879d8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -599,8 +599,7 @@ API key.")
(search-input-file inputs "bin/guile"))))))
(add-after 'make-autoloads 'patch-autoloads
(lambda _
- (substitute* (string-append (elpa-directory #$output)
- "/geiser-guile-autoloads.el")
+ (substitute* "geiser-guile-autoloads.el"
;; Activating implementations fails when Geiser is not yet
;; loaded, so let's defer that until it is.
(("\\(geiser-activate-implementation .*\\)" all)
@@ -669,8 +668,7 @@ using geiser.")
(search-input-file inputs "bin/gosh")))))
(add-after 'make-autoloads 'patch-autoloads
(lambda _
- (substitute* (string-append (elpa-directory #$output)
- "/geiser-gauche-autoloads.el")
+ (substitute* "geiser-gauche-autoloads.el"
;; Activating implementations fails when Geiser is not yet
;; loaded, so let's defer that until it is.
(("\\(geiser-activate-implementation .*\\)" all)
@@ -715,8 +713,7 @@ a generic Scheme interaction mode for the GNU Emacs editor.")
(search-input-file inputs "bin/racket"))))))
(add-after 'make-autoloads 'patch-autoloads
(lambda _
- (substitute* (string-append (elpa-directory #$output)
- "/geiser-racket-autoloads.el")
+ (substitute* "geiser-racket-autoloads.el"
;; Activating implementations fails when Geiser is not yet
;; loaded, so let's defer that until it is.
(("\\(geiser-activate-implementation .*\\)" all)
@@ -754,9 +751,7 @@ a generic Scheme interaction mode for the GNU Emacs editor.")
(modify-phases %standard-phases
(add-after 'make-autoloads 'patch-autoloads
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* (string-append
- (elpa-directory (assoc-ref outputs "out"))
- "/geiser-chez-autoloads.el")
+ (substitute* "geiser-chez-autoloads.el"
;; Activating implementations fails when Geiser is not yet
;; loaded, so let's defer that until it is.
;; See <https://gitlab.com/emacs-geiser/chez/-/issues/7>.
@@ -1592,13 +1587,11 @@ on stdout instead of using a socket as the Emacsclient does.")
emacs:%default-include)))))
(add-after 'unpack 'emacs-add-install-to-native-load-path
(assoc-ref emacs:%standard-phases 'add-install-to-native-load-path))
- (add-after 'install 'make-autoloads
+ (add-after 'unpack 'make-autoloads
(assoc-ref emacs:%standard-phases 'make-autoloads))
- (add-after 'make-autoloads 'enable-autoloads-compilation
- (assoc-ref emacs:%standard-phases 'enable-autoloads-compilation))
- (add-after 'enable-autoloads-compilation 'patch-el-files
+ (add-after 'unpack 'patch-el-files
(assoc-ref emacs:%standard-phases 'patch-el-files))
- (add-after 'patch-el-files 'emacs-build
+ (add-after 'install 'emacs-build
(assoc-ref emacs:%standard-phases 'build))
(add-after 'emacs-build 'validate-compiled-autoloads
(assoc-ref emacs:%standard-phases 'validate-compiled-autoloads)))))
@@ -1677,7 +1670,11 @@ libgit2 bindings for Emacs, intended to boost the performance of Magit.")
(replace 'install
(lambda args
(with-directory-excursion "lisp"
- (apply (assoc-ref %standard-phases 'install) args)))))))
+ (apply (assoc-ref %standard-phases 'install) args))))
+ (replace 'build
+ (lambda args
+ (with-directory-excursion "lisp"
+ (apply (assoc-ref %standard-phases 'build) args)))))))
(native-inputs
(list texinfo))
(inputs
@@ -3932,6 +3929,8 @@ defined in RFC 2425 and RFC 2426 to/from The Insidious Big Brother Database
(emacs-substitute-sexps "eweouz.el"
("eweouz-helper-dirs"
`(list ,(string-append #$output "/libexec/eweouz"))))))
+ (add-after 'enter-lisp-dir 'emacs-make-autoloads
+ (assoc-ref emacs:%standard-phases 'make-autoloads))
(add-after 'emacs-patch-variables 'emacs-expand-load-path
(assoc-ref emacs:%standard-phases 'expand-load-path))
(add-after 'emacs-expand-load-path 'emacs-add-install-to-native-load-path
@@ -3939,9 +3938,7 @@ defined in RFC 2425 and RFC 2426 to/from The Insidious Big Brother Database
(add-after 'emacs-add-install-to-native-load-path 'emacs-install
(assoc-ref emacs:%standard-phases 'install))
(add-after 'emacs-install 'emacs-build
- (assoc-ref emacs:%standard-phases 'build))
- (add-after 'emacs-install 'emacs-make-autoloads
- (assoc-ref emacs:%standard-phases 'make-autoloads)))))
+ (assoc-ref emacs:%standard-phases 'build)))))
(native-inputs
(list autoconf
automake
@@ -5610,6 +5607,8 @@ during idle time, while Emacs is doing nothing else.")
;; upgrading" that pdf-tools tries to perform.
(emacs-substitute-variables "pdf-tools.el"
("pdf-tools-handle-upgrades" '()))))
+ (add-after 'enter-lisp-dir 'emacs-make-autoloads
+ (assoc-ref emacs:%standard-phases 'make-autoloads))
(add-after 'emacs-patch-variables 'emacs-expand-load-path
(assoc-ref emacs:%standard-phases 'expand-load-path))
(add-after 'emacs-expand-load-path 'emacs-add-install-to-native-load-path
@@ -5617,9 +5616,7 @@ during idle time, while Emacs is doing nothing else.")
(add-after 'emacs-add-install-to-native-load-path 'emacs-install
(assoc-ref emacs:%standard-phases 'install))
(add-after 'emacs-install 'emacs-build
- (assoc-ref emacs:%standard-phases 'build))
- (add-after 'emacs-install 'emacs-make-autoloads
- (assoc-ref emacs:%standard-phases 'make-autoloads)))))
+ (assoc-ref emacs:%standard-phases 'build)))))
(native-inputs
(list autoconf automake emacs-minimal pkg-config))
(inputs
@@ -16940,6 +16937,10 @@ passive voice.")
(substitute* "testing/lisp/test-org.el"
(("test-org/org-(encode-time|time-string-to-time) .*" all)
(string-append all " (skip-unless nil)\n")))))
+ (replace 'build
+ (lambda args
+ (with-directory-excursion "lisp"
+ (apply (assoc-ref %standard-phases 'build) args))))
(replace 'install
(lambda _
(let ((elpa (elpa-directory #$output))