summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d0bbbd74aa..b29436154e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4984,6 +4984,79 @@ containing words from the rime project.")
and cangjie.")
(license license:gpl2+)))
+(define-public emacs-el2org
+ (package
+ (name "emacs-el2org")
+ (version "0.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tumashu/el2org/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gd3km1swwvg2w0kdi7370f54wgrflxn63gjgssfjc1iyc9sbqwq"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tumashu/el2org")
+ (synopsis "Convert Emacs-lisp file to org file")
+ (description "El2org is a simple tool, which can convert Emacs-lisp file
+to org file, you can use this tool to write orgify commentary.")
+ (license license:gpl2+)))
+
+(define-public emacs-mustache
+ (package
+ (name "emacs-mustache")
+ (version "0.23")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Wilfred/mustache.el/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0k9lcgil7kykkv1ylrgwy1g13ldjjmgi2cwmysgyb2vlj3jbwpdj"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-ht" ,emacs-ht)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/Wilfred/mustache.el")
+ (synopsis "Mustache templating library for Emacs")
+ (description "Mustache templating library for Emacs, mustache is
+a simple web template system, which is described as a logic-less system
+because it lacks any explicit control flow statements, both looping and
+conditional evaluation can be achieved using section tags processing lists
+and lambdas.")
+ (license license:gpl3+)))
+
+(define-public emacs-org2web
+ (package
+ (name "emacs-org2web")
+ (version "0.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/tumashu/org2web/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1c0ixcphlhp4c4qdiwq40bc3yp1gp1llp8pxrk4s7ny9n68s52zp"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-el2org" ,emacs-el2org)
+ ("emacs-ht" ,emacs-ht)
+ ("emacs-mustache" ,emacs-mustache)
+ ("emacs-simple-httpd" ,emacs-simple-httpd)))
+ (home-page "https://github.com/tumashu/org2web")
+ (synopsis "Static site generator based on org-mode ")
+ (description "Org2web is a static site generator based on org-mode,
+which code derived from Kelvin H's org-page.")
+ (license license:gpl2+)))
+
(define-public emacs-xelb
(package
(name "emacs-xelb")