summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 5fc8b8c9f2..c5932a057c 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -250,8 +250,8 @@ console.")
;; Following commits and revision numbers of beta versions listed at
;; https://dolphin-emu.org/download/.
(define-public dolphin-emu
- (let ((commit "a34823df61df65168aa40ef5e82e44defd4a0138")
- (revision "13178"))
+ (let ((commit "f9deb68aee962564b1495ff04c54c015e58d086f")
+ (revision "13669"))
(package
(name "dolphin-emu")
(version (git-version "5.0" revision commit))
@@ -262,6 +262,8 @@ console.")
(url "https://github.com/dolphin-emu/dolphin")
(commit commit)))
(file-name (git-file-name name version))
+ (sha256
+ (base32 "1p8qsxlabgmz3nic0a9ghh9d3lzl5f8i3kmdrrvx6w8kdlp33018"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -273,11 +275,8 @@ console.")
"gettext" "hidapi" "libpng" "libusb" "mbedtls"
"miniupnpc" "MoltenVK" "zlib"))
;; Clean up source.
- (for-each delete-file (find-files "." ".*\\.(bin|dsy|exe|jar|rar)$"))
- #t))
- (sha256
- (base32
- "0j6hnj60iai366kl0kdbn1jkwc183l02g65mp2vq4qb2yd4399l1"))))
+ (for-each delete-file
+ (find-files "." ".*\\.(bin|dsy|exe|jar|rar)$"))))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f
@@ -301,8 +300,7 @@ console.")
(substitute* "Source/Core/VideoBackends/Vulkan/VulkanLoader.cpp"
(("\"vulkan\", 1") (string-append "\"vulkan\""))
(("\"vulkan\"") (string-append "\"" libvulkan "\""))
- (("Common::DynamicLibrary::GetVersionedFilename") ""))
- #t))))
+ (("Common::DynamicLibrary::GetVersionedFilename") ""))))))
;; The FindGTK2 cmake script only checks hardcoded directories for
;; glib/gtk headers.