summaryrefslogtreecommitdiff
path: root/gnu/packages/emulators.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emulators.scm')
-rw-r--r--gnu/packages/emulators.scm24
1 files changed, 7 insertions, 17 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 25439ceadf..166c3b4ec6 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1420,7 +1420,7 @@ as RetroArch.")
(define-public retroarch
(package
(name "retroarch")
- (version "1.9.11")
+ (version "1.15.0")
(source
(origin
(method git-fetch)
@@ -1429,9 +1429,7 @@ as RetroArch.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0hd77kw1f655s40qcz1righdhd9czqyy40rf7gigdag1bkchdx6z"))
- (patches
- (search-patches "retroarch-LIBRETRO_DIRECTORY.patch"))))
+ (base32 "1ii31mc7wfd386rzyxqk8nmx5a13f9iqz47991z4zx0d8gqcchzg"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1449,13 +1447,6 @@ as RetroArch.")
(substitute* "gfx/common/wayland/generate_wayland_protos.sh"
(("/usr/local/share/wayland-protocols")
(string-append wayland-protocols "/share/wayland-protocols")))
- (substitute* "qb/qb.libs.sh"
- (("/bin/true") (which "true")))
-
- ;; Use shared zlib.
- (substitute* '("libretro-common/file/archive_file_zlib.c"
- "libretro-common/streams/trans_stream_zlib.c")
- (("<compat/zlib.h>") "<zlib.h>"))
;; The configure script does not yet accept the extra arguments
;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
@@ -1469,7 +1460,7 @@ as RetroArch.")
;; Non-free software are available through the core updater,
;; disable it. See <https://issues.guix.gnu.org/38360>.
"--disable-update_cores"
- "--disable-builtinminiupnpc")))))))
+ "--disable-builtinzlib")))))))
(inputs
`(("alsa-lib" ,alsa-lib)
("ffmpeg" ,ffmpeg-4)
@@ -1480,7 +1471,6 @@ as RetroArch.")
("libxrandr" ,libxrandr)
("libxv" ,libxv)
("mesa" ,mesa)
- ("miniupnpc" ,miniupnpc)
("openal" ,openal)
("pulseaudio" ,pulseaudio)
("python" ,python)
@@ -1561,14 +1551,14 @@ that compiles to WebAssembly.")
(define-public scummvm
(package
(name "scummvm")
- (version "2.6.1")
+ (version "2.7.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://downloads.scummvm.org/frs/scummvm/" version
"/scummvm-" version ".tar.xz"))
(sha256
- (base32 "1s8psdn3a3hqvvfgmlfxrqqdw8hbr0zyrvirzsnzh6yxmgpvkbwg"))))
+ (base32 "14wrrzai25mh8qra3lsfibx8z6f96cqbnmsfh9kyhkvpc7yiyjs4"))))
(build-system gnu-build-system)
(arguments
(list
@@ -1768,7 +1758,7 @@ This is a part of the TiLP project.")
(define-public mame
(package
(name "mame")
- (version "0.251")
+ (version "0.252")
(source
(origin
(method git-fetch)
@@ -1777,7 +1767,7 @@ This is a part of the TiLP project.")
(commit (apply string-append "mame" (string-split version #\.)))))
(file-name (git-file-name name version))
(sha256
- (base32 "102p6kz4ph9m0sxsyavqhjzg00gmnq8m5mnd5sf14c61d2jc0vzk"))
+ (base32 "07qhcm1v47sy2wj30nx3cbhvcbgki0cl83gabr0miiw60fhgyn6j"))
(modules '((guix build utils)))
(snippet
;; Remove bundled libraries.