summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index bf32187dde..8037ccb565 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -213,7 +213,7 @@
(copy-recursively "unix/resources" share))
#t)))))
(inputs
- (list boost muparser freetype qtbase-5 qtsvg))
+ (list boost muparser freetype qtbase-5 qtsvg-5))
(native-inputs
(list pkg-config which))
(home-page "https://librecad.org/")
@@ -710,7 +710,7 @@ multipole-accelerated algorithm.")
(inputs
`(("qtbase" ,qtbase-5)
("qtserialport" ,qtserialport)
- ("qtsvg" ,qtsvg)
+ ("qtsvg-5" ,qtsvg-5)
("libgit2" ,libgit2)
("boost" ,boost)
("zlib" ,zlib)
@@ -764,7 +764,7 @@ ready for production.")
(native-inputs
(list pkg-config qttools))
(inputs
- (list kcoreaddons kwidgetsaddons qtbase-5 qtsvg sqlite))
+ (list kcoreaddons kwidgetsaddons qtbase-5 qtsvg-5 sqlite))
(home-page "https://qelectrotech.org/")
(synopsis "CAD/CAE editor focusing on schematics drawing features")
(description "QElectroTech, or QET in short, is a desktop application to
@@ -1246,7 +1246,7 @@ the 'showing the effect of'-style of operation.")
mpfr
openssl
qtbase-5
- qtsvg))
+ qtsvg-5))
(home-page "https://github.com/ccoors/Valeronoi")
(synopsis "WiFi mapping companion application for Valetudo")
(description
@@ -2118,7 +2118,7 @@ parallel computing platforms. It also supports serial execution.")
(base32 "0smp1p7wnrj0vh4rmz1cr2krfawc2lzx0pbzmgyay7xdp6jxympr"))))
(build-system gnu-build-system)
(inputs
- (list qtbase-5 qtsvg zlib))
+ (list qtbase-5 qtsvg-5 zlib))
(native-inputs
(list qttools ; for lrelease
unzip))
@@ -2278,7 +2278,7 @@ simulation.")
(list pkg-config))
(inputs
(list qtbase-5
- qtsvg
+ qtsvg-5
openssl
;; Depends on radare2 4.5.1 officially, builds and works fine with
;; radare2 5.0.0 but fails to build with radare2 5.1.1.
@@ -2491,7 +2491,7 @@ comments.")))
python-wrapper
qtbase-5
qtdeclarative
- qtsvg
+ qtsvg-5
qtwebchannel
qtwebengine
qtx11extras
@@ -3426,7 +3426,7 @@ compiled translations. Prebuilt Firmware files are removed.")
qtgraphicaleffects
qtquickcontrols
qtquickcontrols2
- qtsvg))
+ qtsvg-5))
(arguments
`(;; FIXME: tests are disabled, because they cause an infinite loop.
#:tests? #f