summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm115
1 files changed, 55 insertions, 60 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index c9aec482da..b43e058af4 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1357,42 +1357,47 @@ the 'showing the effect of'-style of operation.")
(license license:gpl2+)))
(define-public valeronoi
-(package
- (name "valeronoi")
- (version "0.1.6")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/ccoors/Valeronoi")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1hpyh4mmjnxgkij7a6rynk2ril5413nkdvf8syn0lqvrmibdg7wv"))))
- (build-system cmake-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "./valeronoi-tests")))))))
- (inputs
- (list boost
- cgal
- gmp
- libxkbcommon
- mpfr
- openssl
- qtbase-5
- qtsvg-5))
- (home-page "https://github.com/ccoors/Valeronoi")
- (synopsis "WiFi mapping companion application for Valetudo")
- (description
- "Valeronoi (Valetudo + Voronoi) is a companion for Valetudo for generating
+ (package
+ (name "valeronoi")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ccoors/Valeronoi")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qkhrqkjsmm0h1bxf2ihkqfhdr18xx5x1i2ds1mla13zm0bw2570"))
+ (snippet #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "3rdparty")
+ (substitute* '("tests/test_colormap.cpp"
+ "tests/test_main.cpp")
+ (("catch\\.hpp")
+ "catch2/catch.hpp"))))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./valeronoi-tests")))))))
+ (inputs (list boost
+ cgal
+ gmp
+ libxkbcommon
+ mpfr
+ openssl
+ qtbase
+ qtsvg))
+ (native-inputs (list catch2))
+ (home-page "https://github.com/ccoors/Valeronoi")
+ (synopsis "WiFi mapping companion application for Valetudo")
+ (description
+ "Valeronoi (Valetudo + Voronoi) is a companion for Valetudo for generating
WiFi signal strength maps. It visualizes them using a Voronoi diagram.")
- (license license:gpl3+)))
+ (license license:gpl3+)))
(define-public volk
(package
@@ -3248,18 +3253,21 @@ program that can perform mesh processing tasks in batch mode, without a GUI.")
(delete-file "libpoke/pvm-vm1.c")
(delete-file "libpoke/pvm-vm2.c")))))
(build-system gnu-build-system)
- ;; The GUI, which we elide, requires tcl and tk.
(native-inputs (list bison dejagnu flex libtool pkg-config))
;; FIXME: Enable NBD support by adding `libnbd' (currently unpackaged).
- (inputs (list json-c libgc readline libtextstyle))
+ (inputs (list libgc readline libtextstyle))
(arguments
- ;; To build the GUI, add the `--enable-gui' configure flag.
- ;; To enable the "hyperlink server", add the `--enable-hserver' flag.
- `(#:configure-flags
- '("--enable-mi"
- "--disable-static"
- ;; The emacs files are provided in emacs-poke.
- "--with-lispdir=/tmp/share/emacs")))
+ (list
+ #:imported-modules `((guix build emacs-build-system)
+ (guix build emacs-utils)
+ ,@%gnu-build-system-modules)
+ #:modules '((guix build gnu-build-system)
+ ((guix build emacs-build-system) #:prefix emacs:)
+ (guix build utils))
+ #:configure-flags
+ #~(list "--disable-static"
+ (string-append "--with-lispdir="
+ (emacs:elpa-directory #$output)))))
(home-page "https://www.gnu.org/software/poke/#documentation")
(synopsis "Editing of arbitrary binary data")
(description "GNU poke is an interactive, extensible editor for binary data.
@@ -3269,22 +3277,9 @@ data structures and to operate on them.")
(license license:gpl3+)))
(define-public emacs-poke
- (package
- (inherit poke)
- (name "emacs-poke")
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'expand-load-path 'change-working-directory
- (lambda _ (chdir "etc"))))))
- (inputs '())
- (native-inputs '())
- (synopsis "GNU Poke major modes for Emacs")
- (description
- "This package provides two Emacs major modes for working with GNU Poke:
-@code{Poke Ras mode} and @code{Poke Map mode}.")))
+ ;; The 'emacs-poke' name may eventually refer to 'poke' from ELPA, which is
+ ;; a different beast.
+ (deprecated-package "emacs-poke" poke))
(define-public pcb2gcode
(package