summaryrefslogtreecommitdiff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 4cbcf5d161..6c3846ff76 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -337,7 +337,9 @@ featuring various improvements and bug fixes.")))
"0x37vfp6k0d2z3gnig0hbicvi0jp8v267xjnn3z8jdllpiaa6p3k"))
(snippet
;; Remove a non-free file.
- '(delete-file "doc/psfig.sty"))
+ '(begin
+ (delete-file "doc/psfig.sty")
+ #t))
(patches (search-patches "fastcap-mulSetup.patch"
"fastcap-mulGlobal.patch"))))
(build-system gnu-build-system)
@@ -1086,7 +1088,8 @@ bindings for Python, Java, OCaml and more.")
(substitute* "libr/parse/p/Makefile"
(("LDFLAGS\\+=") "LDFLAGS+=-Wl,-rpath=$(LIBDIR) "))
(substitute* "libr/bin/p/Makefile"
- (("LDFLAGS\\+=") "LDFLAGS+=-Wl,-rpath=$(LIBDIR) "))))))
+ (("LDFLAGS\\+=") "LDFLAGS+=-Wl,-rpath=$(LIBDIR) "))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f; tests require git and network access
@@ -1191,7 +1194,8 @@ high-performance parallel differential evolution (DE) optimization algorithm.")
(("src/ciderlib/input/Makefile") "")
(("src/ciderlib/support/Makefile") "")
(("src/ciderlib/oned/Makefile") "")
- (("src/ciderlib/twod/Makefile") ""))))))
+ (("src/ciderlib/twod/Makefile") ""))
+ #t))))
(build-system gnu-build-system)
(arguments
`(;; No tests for libngspice exist.