summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm48
1 files changed, 21 insertions, 27 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 60b42f69dc..dc3114d58b 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -32,7 +32,6 @@
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages avahi)
- #:use-module (gnu packages bash)
#:use-module (gnu packages bittorrent)
#:use-module (gnu packages check)
#:use-module (gnu packages code)
@@ -304,6 +303,7 @@ Libraries with some extra bells and whistles.")
(let ((efl (assoc-ref %build-inputs "efl")))
(list "-Dsystemd=false"
"-Dpackagekit=false"
+ "-Dwl=true"
(string-append "-Dedje-cc=" efl "/bin/edje_cc")
(string-append "-Deldbus-codegen=" efl "/bin/eldbus-codegen")
(string-append "-Deet=" efl "/bin/eet")))
@@ -315,7 +315,6 @@ Libraries with some extra bells and whistles.")
(setenv "HOME" "/tmp")
(let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
(setxkbmap (assoc-ref inputs "setxkbmap"))
- (utils (assoc-ref inputs "util-linux"))
(libc (assoc-ref inputs "libc"))
(bc (assoc-ref inputs "bc"))
(efl (assoc-ref inputs "efl")))
@@ -346,20 +345,18 @@ Libraries with some extra bells and whistles.")
(substitute* "data/etc/meson.build"
(("/bin/mount") "/run/setuid-programs/mount")
(("/bin/umount") "/run/setuid-programs/umount")
- (("/usr/bin/eject") (string-append utils "/bin/eject")))
+ (("/usr/bin/eject") "/run/current-system/profile/bin/eject"))
(substitute* "src/bin/system/e_system_power.c"
(("systemctl") "loginctl"))
#t))))))
(native-inputs
`(("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
- ("util-linux" ,util-linux)))
+ ("pkg-config" ,pkg-config)))
(inputs
`(("alsa-lib" ,alsa-lib)
("bc" ,bc)
("bluez" ,bluez)
("dbus" ,dbus)
- ("efl" ,efl)
("freetype" ,freetype)
("libxcb" ,libxcb)
("libxext" ,libxext)
@@ -367,7 +364,12 @@ Libraries with some extra bells and whistles.")
("puleseaudio" ,pulseaudio)
("setxkbmap" ,setxkbmap)
("xcb-util-keysyms" ,xcb-util-keysyms)
- ("xkeyboard-config" ,xkeyboard-config)))
+ ("xkeyboard-config" ,xkeyboard-config)
+ ("xorg-server-xwayland" ,xorg-server-xwayland)))
+ (propagated-inputs
+ `(("efl" ,efl)
+ ("libxkbcommon" ,libxkbcommon)
+ ("wayland-protocols" ,wayland-protocols)))
(home-page "https://www.enlightenment.org/about-enlightenment")
(synopsis "Lightweight desktop environment")
(description
@@ -378,17 +380,7 @@ embedded systems.")
(license license:bsd-2)))
(define-public enlightenment-wayland
- (package
- (inherit enlightenment)
- (name "enlightenment-wayland")
- (arguments
- (substitute-keyword-arguments (package-arguments enlightenment)
- ((#:configure-flags flags)
- `(cons* "-Dwl=true" ,flags))))
- (inputs
- `(("wayland-protocols" ,wayland-protocols)
- ("xorg-server-xwayland" ,xorg-server-xwayland)
- ,@(package-inputs enlightenment)))))
+ (deprecated-package "enlightenment-wayland" enlightenment))
(define-public python-efl
(package
@@ -405,13 +397,15 @@ embedded systems.")
(modules '((guix build utils)))
;; Remove files generated by Cython
(snippet
- '(begin
- (copy-file "efl/dbus_mainloop/e_dbus.c" "efl/dbus_mainloop/e_dbus.q")
- (for-each delete-file (find-files "efl" ".*\\.c$"))
- (delete-file "efl/eo/efl.eo_api.h")
- (copy-file "efl/dbus_mainloop/e_dbus.q" "efl/dbus_mainloop/e_dbus.c")
- (delete-file "efl/dbus_mainloop/e_dbus.q")
- #t))))
+ '(begin
+ (for-each (lambda (file)
+ (let ((generated-file
+ (string-append (string-drop-right file 3) "c")))
+ (when (file-exists? generated-file)
+ (delete-file generated-file))))
+ (find-files "efl" "\\.pyx$"))
+ (delete-file "efl/eo/efl.eo_api.h")
+ #t))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -572,14 +566,14 @@ directories.
(define-public evisum
(package
(name "evisum")
- (version "0.5.3")
+ (version "0.5.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.enlightenment.org/rel/apps/"
"evisum/evisum-" version ".tar.xz"))
(sha256
- (base32 "06ws75qfid0xizasw2aqpdhvxl4c31bn66fqa8aq4w0rykzs2r46"))))
+ (base32 "1ip3w2d476g45sivqvm1madfyqmkni9q2i99qqxk53859jgs91pa"))))
(build-system meson-build-system)
(arguments
'(#:tests? #f)) ; no tests