summaryrefslogtreecommitdiff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index c487fc1020..ee017277ee 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -324,13 +324,18 @@ embedded systems.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (zero?
+ (system* "env" "ENABLE_CYTHON=1" "python" "setup.py" "build"))))
(add-before 'build 'set-flags
(lambda _
(setenv "CFLAGS"
(string-append "-I" (assoc-ref %build-inputs "python-dbus")
"/include/dbus-1.0")))))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("python-cython" ,python-cython)))
(inputs
`(("efl" ,efl)
("elementary" ,elementary)