summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm50
1 files changed, 38 insertions, 12 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 2f7f3741e0..6686ab482c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2021 ZmnSCPxj jxPCSnmZ <ZmnSCPxj@protonmail.com>
;;; Copyright © 2021 François J <francois-oss@avalenn.eu>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,6 +57,7 @@
#:use-module (guix build-system go)
#:use-module (guix build-system qt)
#:use-module (guix deprecation)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages aidc)
@@ -307,7 +309,14 @@ and dynamically with report tools based on filtering and graphical charts.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0x6jxwss3wwzbzlwmnwb8yzjk8f9wfawif4f1b74z2qg6hc4r7f6"))))
+ (base32 "0x6jxwss3wwzbzlwmnwb8yzjk8f9wfawif4f1b74z2qg6hc4r7f6"))
+ (snippet '(begin
+ ;; Remove test that fails due to difference in
+ ;; reported error message (missing leading "./" in the
+ ;; file name); started some time after Guix commit
+ ;; 727f05e1e285aa52f5a19ec923fdc2259859b4b1
+ (delete-file "test/regress/BF3C1F82-2.test")
+ #true))))
(build-system cmake-build-system)
(arguments
`(#:modules (,@%cmake-build-system-modules
@@ -346,8 +355,8 @@ and dynamically with report tools based on filtering and graphical charts.")
;; One test fails if it can't set the timezone.
(lambda* (#:key inputs #:allow-other-keys)
(setenv "TZDIR"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
+ (search-input-directory inputs
+ "share/zoneinfo"))
;; Skip failing test BaselineTest_cmd-org.
;; This is a known upstream issue. See
;; https://github.com/ledger/ledger/issues/550
@@ -551,6 +560,14 @@ do so.")
(("sys\\.prefix")
(format #f "\"~a\"" out)))
#t)))
+ (add-after 'unpack 'relax-dnspython-version-requirement
+ ;; The version requirement for dnspython>=2.0,<2.1 makes the
+ ;; sanity-check phase fail, but the application seems to be working
+ ;; fine with dnspython 2.1 (the version we have currently).
+ (lambda _
+ (substitute* "contrib/requirements/requirements.txt"
+ (("dnspython>=.*")
+ "dnspython"))))
(add-after 'unpack 'use-libsecp256k1-input
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "electrum/ecc_fast.py"
@@ -597,6 +614,7 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
("python-pyaes" ,python-pyaes)
("python-pyqt" ,python-pyqt)
("python-pysocks" ,python-pysocks)
+ ("python-qdarkstyle" ,python-qdarkstyle)
("python-qrcode" ,python-qrcode)
("python-requests" ,python-requests)
("python-stem" ,python-stem)
@@ -623,6 +641,11 @@ other machines/servers. Electrum does not download the Bitcoin blockchain.")
(string-append "library_paths = ('"
(assoc-ref inputs "libsecp256k1")
"/lib/libsecp256k1.so.0'")))))
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "contrib/requirements/requirements.txt"
+ (("qdarkstyle==2\\.6\\.8")
+ "qdarkstyle"))))
(add-after 'install 'wrap-qt
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -663,6 +686,11 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
delete-file-recursively
'("external/miniupnp" "external/rapidjson"
"external/unbound"))
+ ;; TODO: Remove the following when upgrading to a newer tagged
+ ;; version as it will already contain the fix for Boost 1.76.
+ (substitute* "contrib/epee/include/storages/portable_storage.h"
+ (("#include \"int-util.h\"" all)
+ (string-append all "\n#include <boost/mpl/contains.hpp>")))
#t))
(sha256
(base32 "1spsf7m3x4psp9s7mivr6x4886jnbq4i8ll2dl8bv5bsdhcd3pjm"))))
@@ -792,10 +820,10 @@ the Monero command line client and daemon.")
(arguments
`(#:tests? #f ; No tests
#:configure-flags
- (list "-DARCH=default"
- "-DENABLE_PASS_STRENGTH_METER=ON"
- (string-append "-DReadline_ROOT_DIR="
- (assoc-ref %build-inputs "readline")))
+ ,#~(list "-DARCH=default"
+ "-DENABLE_PASS_STRENGTH_METER=ON"
+ (string-append "-DReadline_ROOT_DIR="
+ #$(this-package-input "readline")))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'extract-monero-sources
@@ -803,9 +831,8 @@ the Monero command line client and daemon.")
;; to build the GUI.
(lambda* (#:key inputs #:allow-other-keys)
(mkdir-p "monero")
- (invoke "tar" "-xv" "--strip-components=1"
- "-C" "monero"
- "-f" (assoc-ref inputs "monero-source"))))
+ (copy-recursively (assoc-ref inputs "monero-source")
+ "monero")))
(add-after 'extract-monero-sources 'fix-build
(lambda _
(substitute* "src/version.js.in"
@@ -825,8 +852,7 @@ the Monero command line client and daemon.")
;; The monerod program must be available so that monero-wallet-gui
;; can start a Monero daemon if necessary.
(lambda* (#:key inputs outputs #:allow-other-keys)
- (symlink (string-append (assoc-ref inputs "monero")
- "/bin/monerod")
+ (symlink (search-input-file inputs "/bin/monerod")
(string-append (assoc-ref outputs "out")
"/bin/monerod")))))))
(home-page "https://web.getmonero.org/")