summaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm38
1 files changed, 37 insertions, 1 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 5c08662f05..9f2d055048 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1724,7 +1724,9 @@ that allows you to run services and through them access the Bitcoin Cash network
(lambda _
(substitute* "setup.py"
(("'google-api-python-client',") ""))
- #t)))))
+ #t))
+ ;; No module named 'google_auth_oauthlib'
+ (delete 'sanity-check))))
(inputs
(list python-beautifulsoup4
python-bottle
@@ -1942,3 +1944,37 @@ providing common functions for the technical analysis of financial market data."
"TA-Lib is a library providing common functions for the technical
analysis of financial market data.")
(license license:bsd-3)))
+
+(define-public python-mt-940
+ (package
+ (name "python-mt-940")
+ (version "4.23.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WoLpH/mt940.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0z9w1qalcphsck3j6vkrs7k47ah9zq2rv0lm9nmcsgwpyp59qkyf"))))
+ (properties '(("upstream-name" #{.}# "mt-940")))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ ;; Remove custom --cov flags.
+ (delete-file "pytest.ini")
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-flake8
+ python-pytest
+ python-pyyaml))
+ (home-page "https://mt940.readthedocs.io/")
+ (synopsis "Python parser for MT940-encoded SWIFT data")
+ (description
+ "A library to parse MT940 files, a bank account statement exchange
+format used by SWIFT. It returns smart Python collections for statistics
+and manipulation.")
+ (license license:bsd-3)))