summaryrefslogtreecommitdiff
path: root/gnu/packages/fltk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fltk.scm')
-rw-r--r--gnu/packages/fltk.scm41
1 files changed, 33 insertions, 8 deletions
diff --git a/gnu/packages/fltk.scm b/gnu/packages/fltk.scm
index 6aee41d31f..7a41460325 100644
--- a/gnu/packages/fltk.scm
+++ b/gnu/packages/fltk.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17,7 +18,10 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages fltk)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:select (lgpl2.0))
+ #:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages image)
#:use-module (gnu packages xorg)
#:use-module (gnu packages gl)
#:use-module (guix packages)
@@ -27,7 +31,7 @@
(define-public fltk
(package
(name "fltk")
- (version "1.3.2")
+ (version "1.3.3")
(source
(origin
(method url-fetch)
@@ -35,21 +39,42 @@
"/fltk-" version "-source.tar.gz"))
(sha256
(base32
- "1974brlk723095vf8z72kazq1cbqr9a51kq6b0xda6zkjkgl8q0p"))))
+ "15qd7lkz5d5ynz70xhxhigpz3wns39v9xcf7ggkl0792syc8sfgq"))
+ (patches (list (search-patch "fltk-shared-lib-defines.patch")))))
(build-system gnu-build-system)
- (inputs
- `(("libx11" ,libx11)
- ("mesa" ,mesa)))
+ (inputs
+ `(("libjpeg" ,libjpeg-8) ;jpeg_read_header argument error in libjpeg-9
+ ("libpng" ,libpng)
+ ("libx11" ,libx11)
+ ("mesa" ,mesa)
+ ("zlib" ,zlib)))
(arguments
`(#:tests? #f ;TODO: compile programs in "test" dir
- #:configure-flags '("--enable-shared")
+ #:configure-flags
+ (list "--enable-shared"
+ (string-append "DSOFLAGS=-Wl,-rpath=" %output "/lib"))
#:phases
(alist-cons-before
'configure 'patch-makeinclude
(lambda _
(substitute* "makeinclude.in"
(("/bin/sh") (which "sh"))))
- %standard-phases)))
+ (alist-cons-after
+ 'install 'patch-config
+ ;; Provide -L flags for image libraries when querying fltk-config to
+ ;; avoid propagating inputs.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (use-modules (srfi srfi-26))
+ (let* ((conf (string-append (assoc-ref outputs "out")
+ "/bin/fltk-config"))
+ (jpeg (assoc-ref inputs "libjpeg"))
+ (png (assoc-ref inputs "libpng"))
+ (zlib (assoc-ref inputs "zlib")))
+ (substitute* conf
+ (("-ljpeg") (string-append "-L" jpeg "/lib -ljpeg"))
+ (("-lpng") (string-append "-L" png "/lib -lpng"))
+ (("-lz") (string-append "-L" zlib "/lib -lz")))))
+ %standard-phases))))
(home-page "http://www.fltk.org")
(synopsis "3D C++ GUI library")
(description "FLTK is a C++ GUI toolkit providing modern GUI functionality