summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 8e829c6c17..2d653abf32 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -918,6 +918,50 @@ all languages with a consistent look and aesthetic. Its goal is to properly
display all Unicode symbols.")
(license license:silofl1.1)))
+(define-public font-google-noto-sans-cjk
+ (package
+ (name "font-google-noto-sans-cjk")
+ (version "2.004")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/googlefonts/noto-cjk/releases/download/Sans"
+ version "/03_NotoSansCJK-OTC.zip"))
+ (file-name (string-append name "-" version ".zip"))
+ (sha256
+ (base32 "1v9yda7r98g4a3pk0y3cjbgc1i2lv4ax0f0v6aqasfzz4ldlx3sj"))))
+ (build-system font-build-system)
+ (home-page "https://www.google.com/get/noto/")
+ (synopsis "Fonts to cover all languages")
+ (description "Google Noto Fonts is a family of fonts designed to support
+all languages with a consistent look and aesthetic. Its goal is to properly
+display all Unicode symbols. This package provides the Sans Serif variant of
+CJK fonts.")
+ (license license:silofl1.1)))
+
+(define-public font-google-noto-serif-cjk
+ (package
+ (name "font-google-noto-serif-cjk")
+ (version "2.001")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/googlefonts/noto-cjk/releases/download/Serif"
+ version "/04_NotoSerifCJKOTC.zip"))
+ (file-name (string-append name "-" version ".zip"))
+ (sha256
+ (base32 "1l6r3sz2s0vcyfx6ria7wqcq45zp40gxgg97lh8hpmajhzw301ig"))))
+ (build-system font-build-system)
+ (home-page "https://www.google.com/get/noto/")
+ (synopsis "Fonts to cover all languages")
+ (description "Google Noto Fonts is a family of fonts designed to support
+all languages with a consistent look and aesthetic. Its goal is to properly
+display all Unicode symbols. This package provides the Serif variant of CJK
+fonts.")
+ (license license:silofl1.1)))
+
(define-public font-google-roboto
(package
(name "font-google-roboto")
@@ -2708,6 +2752,27 @@ This package contains the following outputs:
")
(license license:gpl2)))
+(define-public font-arphic-ukai
+ (package
+ (name "font-arphic-ukai")
+ (version "0.2.20080216.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://deb.debian.org/debian/pool/main"
+ "/f/fonts-arphic-ukai/fonts-arphic-ukai_"
+ version ".orig.tar.bz2"))
+ (sha256
+ (base32
+ "1lp3i9m6x5wrqjkh1a8vpyhmsrhvsa2znj2mx13qfkwza5rqv5ml"))))
+ (build-system font-build-system)
+ (home-page "https://www.freedesktop.org/wiki/Software/CJKUnifonts/")
+ (synopsis "Truetype fonts for Taiwanese and Hakka")
+ (description
+ "This package provides a set of Truetype fonts, which contain all
+characters necessary to display Taiwanese and Hakka.")
+ (license (license:fsdg-compatible
+ "https://www.freedesktop.org/wiki/Arphic_Public_License/"))))
+
(define-public font-atui-feather
(let ((version "0")
(commit "c51fe7cedbcf2cbf4f1b993cef5d8def612dec1d")