summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm106
1 files changed, 106 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 4acebeb405..0f123c3ab1 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -170,6 +170,45 @@ itself."))))
sans-serif designed for on-screen reading. It is used by GNOME@tie{}3.")
(license license:silofl1.1)))
+(define-public font-lato
+ (package
+ (name "font-lato")
+ (version "2.010")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.latofonts.com/download/Lato2OFL.zip"))
+ (sha256
+ (base32
+ "1f5540g0ja1nx3ddd3ywn77xc81ssrxpq8n3gyb9sabyq2b4xda2"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils)
+ (srfi srfi-26))
+
+ (let ((PATH (string-append (assoc-ref %build-inputs
+ "unzip")
+ "/bin"))
+ (font-dir (string-append %output
+ "/share/fonts/truetype")))
+ (setenv "PATH" PATH)
+ (system* "unzip" (assoc-ref %build-inputs "source"))
+
+ (mkdir-p font-dir)
+ (for-each (lambda (ttf)
+ (install-file ttf font-dir))
+ (find-files "." "\\.ttf$"))))))
+
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "http://www.latofonts.com/lato-free-fonts/")
+ (synopsis "Lato sans-serif typeface")
+ (description
+ "Lato is a sanserif typeface family. It covers over 3000 glyphs per style.
+The Lato 2.010 family supports more than 100 Latin-based languages, over
+50 Cyrillic-based languages as well as Greek and IPA phonetics.")
+ (license license:silofl1.1)))
+
(define-public font-gnu-freefont-ttf
(package
(name "font-gnu-freefont-ttf")
@@ -831,6 +870,24 @@ designed to work well in user interface environments.")
(description "This is the typeface used by Mozilla in Firefox OS.")
(license license:silofl1.1)))
+(define-public font-fira-sans
+ (package
+ (name "font-fira-sans")
+ (version "4.202")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mozilla/Fira/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r6zdnqqp4bgq5nmgqbj0vvj7x1h9w912851ggbl9wc7fdjnjqnq"))))
+ (build-system font-build-system)
+ (home-page "http://mozilla.github.io/Fira/")
+ (synopsis "Mozilla's Fira Sans Font")
+ (description "This is the typeface used by Mozilla in Firefox OS.")
+ (license license:silofl1.1)))
+
(define-public font-awesome
(package
(name "font-awesome")
@@ -1070,3 +1127,52 @@ emphasis while still being readable.")
"The Font Software may be sold as part of a larger software package but
no copy of one or more of the Font Software typefaces may be sold by
itself."))))
+
+(define-public font-dosis
+ (package
+ (name "font-dosis")
+ (version "1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.impallari.com/media/releases/dosis-"
+ "v" version ".zip"))
+ (sha256
+ (base32
+ "1qhci68f68mf87jd69vjf9qjq3wydgw1q7ivn3amjb65ls1s0c4s"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder (begin
+ (use-modules (guix build utils)
+ (srfi srfi-26))
+
+ (let ((PATH (string-append (assoc-ref %build-inputs
+ "unzip")
+ "/bin"))
+ (ttf-dir (string-append %output
+ "/share/fonts/truetype"))
+ (otf-dir (string-append %output
+ "/share/fonts/opentype")))
+ (setenv "PATH" PATH)
+ (system* "unzip" (assoc-ref %build-inputs "source"))
+
+ (mkdir-p ttf-dir)
+ (mkdir-p otf-dir)
+ (for-each (lambda (ttf)
+ (install-file ttf ttf-dir))
+ (find-files "." "\\.ttf$"))
+ (for-each (lambda (otf)
+ (install-file otf otf-dir))
+ (find-files "." "\\.otf$"))))))
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "http://www.impallari.com/dosis")
+ (synopsis "Very simple, rounded, sans serif family")
+ (description
+ "Dosis is a very simple, rounded, sans serif family.
+The lighter weights are minimalist. The bolder weights have more personality.
+The medium weight is nice and balanced. The overall result is a family
+that's clean and modern, and can express a wide range of voices & feelings.
+It comes in 7 incremental weights:
+ExtraLight, Light, Book, Medium, Semibold, Bold & ExtraBold")
+ (license license:silofl1.1)))