summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index b65d3a9e94..07c1b6f750 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -764,17 +764,15 @@ glyph designs, not just an added slant.")
(define-public font-hack
(package
(name "font-hack")
- (version "2.020")
+ (version "3.000")
(source (origin
(method url-fetch/zipbomb)
(uri (string-append
- "https://github.com/chrissimpkins/Hack/releases/download/v"
- version "/Hack-v"
- (string-replace-substring version "." "_")
- "-ttf.zip"))
+ "https://github.com/source-foundry/Hack/releases/download/v"
+ version "/Hack-v" version "-ttf.zip"))
(sha256
(base32
- "16kkmc3psckw1b7k07ccn1gi5ymhlg9djh43nqjzg065g6p6d184"))))
+ "0h6slqg25a6cq57k6rh5hmnk8dxbprmf8shs4iyj1pc83sw6b1r3"))))
(build-system font-build-system)
(home-page "https://sourcefoundry.org/hack/")
(synopsis "Typeface designed for source code")
@@ -782,9 +780,12 @@ glyph designs, not just an added slant.")
"Hack is designed to be a workhorse typeface for code. It expands upon
the Bitstream Vera & DejaVu projects, provides 1561 glyphs, and includes
Powerline support.")
- (license (license:x11-style
- "https://github.com/chrissimpkins/Hack/blob/master/LICENSE.md"
- "Hack Open Font License v2.0"))))
+ (license
+ ;; See https://github.com/source-foundry/Hack/issues/271 for details.
+ (list license:expat ; the Hack modifications to...
+ license:public-domain ; ...the DejaVu modifications to...
+ (license:x11-style ; ...the Bitstream Vera typeface
+ "file://LICENSE.md" "Bitstream Vera License")))))
(define-public font-adobe-source-code-pro
(package