summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 19597f0519..031df7faa7 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -137,7 +137,8 @@ TrueType (TTF) files.")
(lambda* (#:key outputs #:allow-other-keys)
(let ((conf-dir (string-append (assoc-ref outputs "out")
"/share/fontconfig/conf.avail")))
- (copy-recursively "fontconfig" conf-dir)))))))
+ (copy-recursively "fontconfig" conf-dir)
+ #t))))))
(home-page "https://dejavu-fonts.github.io/")
(synopsis "Vera font family derivate with additional characters")
(description "DejaVu provides an expanded version of the Vera font family
@@ -406,14 +407,15 @@ for long periods of working with computers (8 or more hours per day).")
(string-append (assoc-ref %outputs out)
"/share/fonts/opentype")))))
(setenv "PATH" PATH)
- (system* tar "xvf" (assoc-ref %build-inputs "source"))
+ (invoke tar "xvf" (assoc-ref %build-inputs "source"))
(chdir (string-append "source-han-sans-" ,version "R"))
(install-opentype-fonts "OTC" "out")
(install-opentype-fonts "SubsetOTF/CN" "cn")
(install-opentype-fonts "SubsetOTF/JP" "jp")
(install-opentype-fonts "SubsetOTF/KR" "kr")
(install-opentype-fonts "SubsetOTF/TW" "tw")
- (for-each delete-file (find-files %output "\\.zip$"))))))
+ (for-each delete-file (find-files %output "\\.zip$"))
+ #t))))
(native-inputs
`(("gzip" ,gzip)
("tar" ,tar)))
@@ -948,7 +950,7 @@ vector graphics.")
(src-pcf-dir (string-append "tamzen-font-Tamzen-"
,version "/pcf")))
(setenv "PATH" PATH)
- (system* tar "xvf" (assoc-ref %build-inputs "source"))
+ (invoke tar "xvf" (assoc-ref %build-inputs "source"))
(mkdir-p font-dir)
(mkdir-p psf-dir)
(chdir src-pcf-dir)
@@ -1167,7 +1169,7 @@ itself."))))
(otf-dir (string-append %output
"/share/fonts/opentype")))
(setenv "PATH" PATH)
- (system* "unzip" (assoc-ref %build-inputs "source"))
+ (invoke "unzip" (assoc-ref %build-inputs "source"))
(mkdir-p ttf-dir)
(mkdir-p otf-dir)
@@ -1176,7 +1178,8 @@ itself."))))
(find-files "." "\\.ttf$"))
(for-each (lambda (otf)
(install-file otf otf-dir))
- (find-files "." "\\.otf$"))))))
+ (find-files "." "\\.otf$"))
+ #t))))
(native-inputs `(("unzip" ,unzip)))
(home-page "http://www.impallari.com/dosis")
(synopsis "Very simple, rounded, sans serif family")