summaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm107
1 files changed, 102 insertions, 5 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 8afb453970..c37303892b 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -44,6 +44,9 @@
;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2022 Kitzman <kitzman@disroot.org>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1496,7 +1499,7 @@ programming. Iosevka is completely generated from its source code.")
(define-public font-sarasa-gothic
(package
(name "font-sarasa-gothic")
- (version "0.31.2")
+ (version "0.36.0")
(source
(origin
(method url-fetch)
@@ -1504,7 +1507,7 @@ programming. Iosevka is completely generated from its source code.")
"/releases/download/v" version
"/sarasa-gothic-ttc-" version ".7z"))
(sha256
- (base32 "0p67qyhm266s6q17islqvwch807fy5slgp2symrl0z665vp6hycj"))))
+ (base32 "0rr6qrf49zx3cl1pv7063l12nnj2nm9p4di3frp0p4ci9l7b4xmw"))))
(build-system font-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -1995,7 +1998,7 @@ This package provides the TrueType fonts.")
(define-public font-jetbrains-mono
(package
(name "font-jetbrains-mono")
- (version "2.221")
+ (version "2.242")
(source
(origin
(method url-fetch)
@@ -2003,7 +2006,7 @@ This package provides the TrueType fonts.")
(string-append "https://github.com/JetBrains/JetBrainsMono/releases/"
"download/v" version "/JetBrainsMono-" version ".zip"))
(sha256
- (base32 "1acrgv2q9vxviirpi01xy67pkkswyssw4dn5pgyvrnjxr85cgjrg"))))
+ (base32 "17qs985v38x3rcg3v4av3qynwr4gvixrj50vjzy7zkkny575ncaf"))))
(build-system font-build-system)
(arguments
`(#:phases
@@ -2463,4 +2466,98 @@ converted from the Type 1 originals by Matthew Butterick.")
"Bitstream contributed the Charter family "
"to the X Consortium in 1992. "
"The license is also embedded in the font metadata."))))))
-/
+
+(define-public font-termsyn
+ (package
+ (name "font-termsyn")
+ (version "1.8.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/termsyn/termsyn-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "15vsmc3nmzl0pkgdpr2993da7p38fiw2rvcg01pwldzmpqrmkpn6"))))
+ (build-system font-build-system)
+ (outputs '("out" "psf" "otf"))
+ (native-inputs (list fontforge))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'install 'build
+ (lambda _
+ (use-modules (ice-9 regex)
+ (ice-9 match))
+ (define (pcf2 name ext)
+ (invoke "fontforge" "-lang=ff" "-c"
+ (string-append "Open('"
+ name
+ "');"
+ "Generate('"
+ (basename name "pcf")
+ ext
+ "','ttf')")))
+ (for-each (lambda (pcf)
+ (pcf2 pcf "otf"))
+ (find-files "." "\\.pcf$")) #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((pcf (assoc-ref outputs "out")) (psf (assoc-ref
+ outputs
+ "psf"))
+ (otf (assoc-ref outputs "otf"))
+ (pcf-font-dir (string-append pcf
+ "/share/fonts/termsyn"))
+ (otf-font-dir (string-append otf
+ "/share/fonts/termsyn-otf"))
+ (psf-font-dir (string-append psf
+ "/share/kbd/consolefonts")))
+ (mkdir-p pcf-font-dir)
+ (mkdir-p otf-font-dir)
+ (mkdir-p psf-font-dir)
+ (for-each (lambda (pcf)
+ (install-file pcf pcf-font-dir))
+ (find-files "." "\\.pcf$"))
+ (for-each (lambda (psfu)
+ (install-file psfu psf-font-dir))
+ (find-files "." "\\.psfu$"))
+ (for-each (lambda (otf)
+ (install-file otf otf-font-dir))
+ (find-files "." "\\.otf$"))) #t)))))
+ (home-page "https://sourceforge.net/projects/termsyn/")
+ (synopsis "Monospaced font based on terminus and tamsyn")
+ (description
+ "Termsyn is a clean monospaced bitmap font based on Terminus and Tamsyn.
+
+This package contains the following outputs:
+@enumerate
+@item out: pcf font
+@item otf: otf font
+@item psf: psfu font
+@end enumerate
+")
+ (license license:gpl2)))
+
+(define-public font-atui-feather
+ (let ((version "0")
+ (commit "c51fe7cedbcf2cbf4f1b993cef5d8def612dec1d")
+ (revision "1"))
+ (package
+ (name "font-atui-feather")
+ (version (git-version version revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (commit commit)
+ (url "https://github.com/AT-UI/feather-font/")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hk12bjlsh0j6kd0sz3nwax259afdi6dxws4x88yz5ssxic1ng2j"))))
+ (build-system font-build-system)
+ (home-page "https://at-ui.github.io/feather-font/")
+ (synopsis "Iconfont version of Feather")
+ (description
+ "Feather is a collection of simply beautiful icons. Each
+icon is designed on a 24x24 grid with an emphasis on simplicity, consistency,
+and readability. This package bundles those icons into a font.")
+ (license license:expat))))