summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm132
1 files changed, 110 insertions, 22 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 928345385e..f63c2dcdd7 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -35,6 +35,9 @@
;;; Copyright © 2023 Alex Devaure <ajadevaure@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022 Samuel Culpepper <sculpepper@newstore.com>
+;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
+;;; Copyright © 2024 Dariqq <dariqq@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -506,7 +509,7 @@ display servers. It supports many different languages and emoji.")
#:make-flags #~(list (string-append "DESTDIR=" #$output)
#$(string-append "CC=" (cc-for-target)))
#:imported-modules `((guix build copy-build-system)
- ,@%gnu-build-system-modules)
+ ,@%default-gnu-imported-modules)
#:modules `((guix build gnu-build-system)
((guix build copy-build-system) #:prefix copy:)
(guix build utils))
@@ -576,9 +579,13 @@ display servers. It supports many different languages and emoji.")
(inputs
(list glib libxml2))
(native-inputs
- (list gettext-minimal pkg-config python xdgmime
- ;; For 'doc' output.
- docbook-xml-4.1.2 docbook-xsl xmlto))
+ (append
+ (if (%current-target-system)
+ (list libxml2 this-package)
+ '())
+ (list gettext-minimal pkg-config python xdgmime
+ ;; For 'doc' output.
+ docbook-xml-4.1.2 docbook-xsl xmlto)))
(outputs (list "out" "doc"))
(home-page "https://www.freedesktop.org/wiki/Software/shared-mime-info")
(synopsis "Database of common MIME types")
@@ -1129,48 +1136,67 @@ manager for the current system.")
(define-public power-profiles-daemon
(package
(name "power-profiles-daemon")
- (version "0.12")
+ (version "0.21")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://gitlab.freedesktop.org/hadess/power-profiles-daemon")
+ (url "https://gitlab.freedesktop.org/upower/power-profiles-daemon")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "1wqcajbj358zpyj6y4h1v34y2yncq76wqxd0jm431habcly0bqyr"))))
+ "0dn3ygv49q7mzs52ch3yphxf4hbry698r1ajj52f6jgw7mpwr5p4"))))
(build-system meson-build-system)
+ (outputs '("out" "doc"))
(arguments
- (list #:configure-flags #~(list "-Dsystemdsystemunitdir=false")
- #:glib-or-gtk? #t
+ (list #:configure-flags #~(list "-Dsystemdsystemunitdir="
+ "-Dpylint=disabled"
+ "-Dgtk_doc=true"
+ (string-append "-Dzshcomp=" #$output
+ "/share/zsh/site-functions/"))
#:phases
#~(modify-phases %standard-phases
- (add-before 'install 'fake-pkexec
- (lambda _ (setenv "PKEXEC_UID" "-1")))
(add-before 'configure 'correct-polkit-dir
(lambda _
- (substitute* "meson.build"
- (("polkit_gobject_dep\\..*")
- (string-append "'" #$output "/share/polkit-1/actions'")))))
+ (setenv "PKG_CONFIG_POLKIT_GOBJECT_1_POLICYDIR"
+ (string-append #$output "/share/polkit-1/actions"))))
(add-after 'install 'wrap-program
(lambda _
(wrap-program
(string-append #$output "/bin/powerprofilesctl")
- `("GUIX_PYTHONPATH" = (,(getenv "GUIX_PYTHONPATH")))
- `("GI_TYPELIB_PATH" = (,(getenv "GI_TYPELIB_PATH")))))))))
+ `("GUIX_PYTHONPATH" = (,(string-append
+ #$(this-package-input "python-pygobject")
+ "/lib/python"
+ #$(version-major+minor
+ (package-version (this-package-input "python")))
+ "/site-packages"))))))
+ (add-after 'install 'move-docs
+ (lambda _
+ (mkdir-p (string-append #$output:doc "/share"))
+ (rename-file
+ (string-append #$output "/share/gtk-doc")
+ (string-append #$output:doc "/share/gtk-doc")))))))
(native-inputs
- (list `(,glib "bin") gobject-introspection pkg-config python vala))
+ (list `(,glib "bin")
+ gtk-doc/stable
+ libxslt
+ pkg-config
+ python
+ python-argparse-manpage
+ python-dbusmock
+ python-shtab
+ umockdev))
(inputs
- (list bash-minimal ;for 'wrap-program'
- dbus
- dbus-glib
+ (list bash-minimal ;for 'wrap-program'
+ bash-completion
libgudev
- glib polkit
+ glib
+ polkit
python
python-pygobject
upower))
- (home-page "https://gitlab.freedesktop.org/hadess/power-profiles-daemon")
+ (home-page "https://gitlab.freedesktop.org/upower/power-profiles-daemon")
(synopsis "Power profile handling over D-Bus")
(description
"power-profiles-daemon offers to modify system behaviour based upon
@@ -1532,6 +1558,37 @@ sent to a Wayland window, such as key presses. It is analogous to the X11 tool
XEv.")
(license license:expat)))
+(define-public wlr-protocols
+ (let ((commit "2b8d43325b7012cc3f9b55c08d26e50e42beac7d")
+ (revision "0"))
+ (package
+ (name "wlr-protocols")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/wlroots/wlr-protocols.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17blwww6rcrahwc6h6j68gh6wjbj14if3mihpxymfdw5pwl72rav"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:make-flags
+ #~(list (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list wayland)) ;For wayland-scanner.
+ (home-page "https://gitlab.freedesktop.org/wlroots/wlr-protocols")
+ (synopsis
+ "Wayland protocols designed for use in wlroots (and other compositors)")
+ (description
+ "This package provides Wayland protocols designed for use in wlroots (and
+other compositors).")
+ (license license:expat))))
+
(define-public wtype
(package
(name "wtype")
@@ -3141,3 +3198,34 @@ notifies the user using any notification daemon implementing
"Waypipe is a proxy for Wayland clients, with the aim of
supporting behavior like @samp{ssh -X}.")
(license license:expat)))
+
+(define-public libdecor
+ (package
+ (name "libdecor")
+ (version "0.2.2")
+ (source
+ (origin (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/libdecor/libdecor")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05rxchwzhnkm91kcr30mavizkp25wgjlhb6lcraa456pw7vgb04q"))))
+ (build-system meson-build-system)
+ (native-inputs (list cmake pkg-config))
+ (inputs (list cairo
+ dbus
+ egl-wayland
+ gtk+
+ libglvnd
+ libxkbcommon
+ pango
+ wayland
+ wayland-protocols))
+ (home-page "https://gitlab.freedesktop.org/libdecor/libdecor")
+ (synopsis "Client-side decorations library for Wayland clients")
+ (description "libdecor is a library that can help Wayland clients draw
+window decorations for them. It aims to provide multiple backends that
+implements the decoration drawing.")
+ (license license:expat)))