summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm48
1 files changed, 26 insertions, 22 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index d7cd2cdf40..4c5c86b8f7 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -519,14 +519,14 @@ freedesktop.org project.")
;; Updating this will rebuild over 700 packages through libinput-minimal.
(package
(name "libinput")
- (version "1.19.2")
+ (version "1.19.4")
(source (origin
(method url-fetch)
(uri (string-append "https://freedesktop.org/software/libinput/"
"libinput-" version ".tar.xz"))
(sha256
(base32
- "10xqk05mkvsyxfxpn3vwkwb7j22d38wlbg1l1k37f6pfyc59zhqg"))))
+ "0h5lz54rrl48bhi3vki6s08m6rn2h62rlf08dhgchdm9nmqaaczz"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Ddocumentation=false")
@@ -1526,7 +1526,7 @@ these interfaces, based on the useradd, usermod and userdel commands.")
(define-public libmbim
(package
(name "libmbim")
- (version "1.20.2")
+ (version "1.26.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1534,7 +1534,7 @@ these interfaces, based on the useradd, usermod and userdel commands.")
"libmbim-" version ".tar.xz"))
(sha256
(base32
- "16q550sy84izi5ic3sbbhjnnka2fwhj8vvdrirpn9xspbsgbc3sm"))))
+ "1ncaarl4lgc7i52rwz50yq701wk2rr478cjybxbifsjqqk2cx27n"))))
(build-system gnu-build-system)
(native-inputs
(list `(,glib "bin") ; for glib-mkenums
@@ -1556,7 +1556,7 @@ which speak the Mobile Interface Broadband Model (MBIM) protocol.")
(define-public libqmi
(package
(name "libqmi")
- (version "1.24.14")
+ (version "1.30.8")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1564,7 +1564,7 @@ which speak the Mobile Interface Broadband Model (MBIM) protocol.")
"libqmi-" version ".tar.xz"))
(sha256
(base32
- "0zshxqbm9ldybgrzh7pjmwmfjvvvfd0xh8qhgl8xiqdb9ply73r0"))))
+ "140rmjw436rh6rqmnfw6yaflpffd27ilwcv4s9jvvl1skv784946"))))
(build-system gnu-build-system)
(inputs
(list libgudev))
@@ -1586,7 +1586,7 @@ which speak the Qualcomm MSM Interface (QMI) protocol.")
(define-public modem-manager
(package
(name "modem-manager")
- (version "1.12.10")
+ (version "1.18.10")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1594,19 +1594,23 @@ which speak the Qualcomm MSM Interface (QMI) protocol.")
"ModemManager-" version ".tar.xz"))
(sha256
(base32
- "1apq9camys2gaw6y6ic1ld20cncfwpmxnzvh4j5zkbbjpf5hbcxj"))))
+ "1sv53lvz9nfbq6jzprl5xhai0vylc01kglcdrgz2vszf5615y98n"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
- `(,(string-append "--with-udev-base-dir=" %output "/lib/udev"))))
+ (list
+ #:configure-flags
+ #~(list (string-append "--with-udev-base-dir=" #$output "/lib/udev"))))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-mkenums
- ("gobject-introspection" ,gobject-introspection)
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)
- ;; For testing.
- ("dbus" ,dbus)))
+ (list gettext-minimal
+ `(,glib "bin") ; for glib-mkenums
+ gobject-introspection
+ pkg-config
+ vala
+ ;; For testing.
+ dbus
+ python
+ python-dbus
+ python-pygobject))
(propagated-inputs
(list glib)) ; required by mm-glib.pc
(inputs
@@ -1943,15 +1947,15 @@ manually by a user.")
(define-public perl-file-basedir
(package
(name "perl-file-basedir")
- (version "0.08")
+ (version "0.09")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/K/KI/KIMRYAN/"
+ (uri (string-append "mirror://cpan/authors/id/P/PL/PLICEASE/"
"File-BaseDir-" version ".tar.gz"))
(sha256
(base32
- "1qq5ag9zffx8zc5i9b4z03ar80pqj4drgk3vjdlyfapjwb9zqrf0"))))
+ "1nb757cyyy80xln147qgns113i2ivfpgcfhsxw8qzb322llgg9kd"))))
(build-system perl-build-system)
(native-inputs
(list perl-module-build perl-file-which perl-test-pod
@@ -1995,7 +1999,7 @@ applications define in those files.")
(define-public perl-file-mimeinfo
(package
(name "perl-file-mimeinfo")
- (version "0.29")
+ (version "0.33")
(source
(origin
(method url-fetch)
@@ -2003,7 +2007,7 @@ applications define in those files.")
"File-MimeInfo-" version ".tar.gz"))
(sha256
(base32
- "1sh8r6vczyz08zm8vfsjmkg6a165wch54akjdrd1vbifcmwjg5pi"))))
+ "1i5iw6ri0w9clwpqf40xmsh4isc8xvx2lyf2r5g34886i6rsdgpn"))))
(build-system perl-build-system)
(inputs
;; TODO(staging): Make unconditional.