summaryrefslogtreecommitdiff
path: root/gnu/packages/freedesktop.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/freedesktop.scm')
-rw-r--r--gnu/packages/freedesktop.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 5d8493b328..63adb4d076 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -259,6 +259,12 @@ the freedesktop.org XDG Base Directory specification.")
#:make-flags '("PKTTYAGENT=/run/current-system/profile/bin/pkttyagent")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-locale-header
+ (lambda _
+ ;; Fix compilation with glibc >= 2.26, which removed xlocale.h.
+ ;; This can be removed for elogind 234.
+ (substitute* "src/basic/parse-util.c"
+ (("xlocale\\.h") "locale.h"))))
(add-before 'configure 'autogen
(lambda _
(and (zero? (system* "intltoolize" "--force" "--automake"))