summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm327
1 files changed, 158 insertions, 169 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 87ef1c8233..5825b8d936 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -68,7 +68,7 @@
;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
-;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022, 2023 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
@@ -216,7 +216,6 @@
#:use-module (gnu packages xml)
#:use-module (guix build-system copy)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
@@ -288,7 +287,7 @@
("libxmu" ,libxmu)
("libxt" ,libxt)
("sdl" ,(sdl-union (list sdl sdl-mixer)))))
- (home-page "http://abe.sourceforge.net")
+ (home-page "https://abe.sourceforge.net")
(synopsis "Scrolling, platform-jumping, ancient pyramid exploring game")
(description
"Abe's Amazing Adventure is a scrolling,
@@ -402,7 +401,7 @@ mouse and joystick control, and original music.")
(inputs
`(("allegro" ,allegro-4)
("dumb" ,dumb-allegro4)))
- (home-page "http://allegator.sourceforge.net/")
+ (home-page "https://allegator.sourceforge.net/")
(synopsis "Retro platform game")
(description
"Guide Alex the Allegator through the jungle in order to save his
@@ -433,7 +432,7 @@ The game includes a built-in editor so you can design and share your own maps.")
freeglut
libpng
libjpeg-turbo))
- (home-page "http://www.armagetronad.org")
+ (home-page "https://www.armagetronad.org")
(synopsis "Tron clone in 3D")
(description "Armagetron Advanced is a multiplayer game in 3d that
attempts to emulate and expand on the lightcycle sequence from the movie Tron.
@@ -545,7 +544,7 @@ regret their insolence.")
zlib))
(native-inputs
(list pkg-config))
- (home-page "http://baronygame.com")
+ (home-page "https://baronygame.com")
(synopsis "3D first-person roguelike game")
(description
"Barony is a first-person roguelike role-playing game with cooperative
@@ -943,7 +942,7 @@ high a score as possible.")
(define-public cataclysm-dda
(package
(name "cataclysm-dda")
- (version "0.F-3")
+ (version "0.G")
(source
(origin
(method git-fetch)
@@ -951,47 +950,44 @@ high a score as possible.")
(url "https://github.com/CleverRaven/Cataclysm-DDA")
(commit version)))
(sha256
- (base32 "1qnsz6az9qp4sbr3y4rcqhlmadrrdzafvd2xwf3db5wn0swvbjys"))
+ (base32 "0y8513yflxfqblk42h5ad0dq5lx5s8k6hhjy65yfcda7amsv9mhx"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags
- (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- "USE_HOME_DIR=1" "DYNAMIC_LINKING=1" "RELEASE=1"
- "LOCALIZE=1" "LANGUAGES=all")
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- ;; Apparently we can't do make on both tiles and a console version at
- ;; the same time anymore, so we have to either "make clean" between
- ;; builds or do some other hackery. See:
- ;; https://github.com/CleverRaven/Cataclysm-DDA/issues/42598#issuecomment-667702746
- (add-after 'install 'make-clean-pre-tiles
- (lambda* (#:key make-flags outputs #:allow-other-keys)
- ;; Change prefix directory and enable tile graphics and sound.
- (invoke "make" "clean")))
- (add-after 'make-clean-pre-tiles 'build-tiles
- (lambda* (#:key make-flags outputs #:allow-other-keys)
- ;; Change prefix directory and enable tile graphics and sound.
- (apply invoke "make" "TILES=1" "SOUND=1"
- (string-append "PREFIX="
- (assoc-ref outputs "tiles"))
- (cdr make-flags))))
- (add-after 'build-tiles 'install-tiles
- (lambda* (#:key make-flags outputs #:allow-other-keys)
- (apply invoke "make" "install" "TILES=1" "SOUND=1"
- (string-append "PREFIX="
- (assoc-ref outputs "tiles"))
- (cdr make-flags)))))
- ;; TODO: Add libtap++ from https://github.com/cbab/libtappp as a native
- ;; input in order to support tests.
- #:tests? #f))
+ (list
+ #:make-flags
+ #~(list (string-append "PREFIX=" #$output)
+ "USE_HOME_DIR=1" "DYNAMIC_LINKING=1" "RELEASE=1"
+ "LOCALIZE=1" "LANGUAGES=all")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ ;; Apparently we can't do make on both tiles and a console version at
+ ;; the same time anymore, so we have to either "make clean" between
+ ;; builds or do some other hackery. See:
+ ;; https://github.com/CleverRaven/Cataclysm-DDA/issues/42598#issuecomment-667702746
+ (add-after 'install 'make-clean-pre-tiles
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ ;; Change prefix directory and enable tile graphics and sound.
+ (invoke "make" "clean")))
+ (add-after 'make-clean-pre-tiles 'build-tiles
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ ;; Change prefix directory and enable tile graphics and sound.
+ (apply invoke "make" "TILES=1" "SOUND=1"
+ (string-append "PREFIX=" #$output:tiles)
+ (cdr make-flags))))
+ (add-after 'build-tiles 'install-tiles
+ (lambda* (#:key make-flags outputs #:allow-other-keys)
+ (apply invoke "make" "install" "TILES=1" "SOUND=1"
+ (string-append "PREFIX=" #$output:tiles)
+ (cdr make-flags)))))
+ ;; TODO: Add libtap++ from https://github.com/cbab/libtappp as a native
+ ;; input in order to support tests.
+ #:tests? #f))
(outputs '("out"
"tiles")) ;for tile graphics and sound support
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
- ("astyle" ,astyle)))
+ (list astyle gettext-minimal pkg-config))
(inputs
(list freetype
libogg
@@ -1288,7 +1284,7 @@ should be placed in @file{~/.local/share/falltergeist}.")
("glu" ,glu)
("libpng" ,libpng)
("sdl" ,(sdl-union (list sdl sdl-mixer sdl-net)))))
- (home-page "http://foobillardplus.sourceforge.net/")
+ (home-page "https://foobillardplus.sourceforge.net/")
(synopsis "3D billiard game")
(description "FooBillard++ is an advanced 3D OpenGL billiard game
based on the original foobillard 3.0a sources from Florian Berger.
@@ -1474,7 +1470,7 @@ real-time combat.")
(list lua))
(inputs
(list glu mesa python sdl2 wxwidgets zlib))
- (home-page "http://golly.sourceforge.net/")
+ (home-page "https://golly.sourceforge.net/")
(synopsis "Software for exploring cellular automata")
(description
"Golly simulates Conway's Game of Life and many other types of cellular
@@ -1978,7 +1974,7 @@ Chess). It is similar to standard chess but this variant is far more complicate
":" (or (getenv "CPATH") ""))))))))
(inputs
(list (sdl-union (list sdl sdl-mixer))))
- (home-page "http://lgames.sourceforge.net/LTris/")
+ (home-page "https://lgames.sourceforge.net/LTris/")
(synopsis "Tetris clone based on the SDL library")
(description
"LTris is a tetris clone: differently shaped blocks are falling down the
@@ -2145,7 +2141,7 @@ role, and your gender.")
#t)))))
(inputs
(list libpng mesa sdl))
- (home-page "http://pipewalker.sourceforge.net/")
+ (home-page "https://pipewalker.sourceforge.net/")
(synopsis "Logical tile puzzle")
(description
"PipeWalker is a simple puzzle game with many diffent themes: connect all
@@ -2194,7 +2190,7 @@ Every puzzle has a complete solution, although there may be more than one.")
pcre
portmidi
(sdl-union (list sdl sdl-image sdl-mixer sdl-net))))
- (home-page "http://prboom-plus.sourceforge.net/")
+ (home-page "https://prboom-plus.sourceforge.net/")
(synopsis "Version of the classic 3D shoot'em'up game Doom")
(description
"PrBoom+ is a Doom source port developed from the original PrBoom project.")
@@ -2823,7 +2819,7 @@ saved automatically, and you can select between currently in progress games.")
Keywords=racing;tracks;~@
Keywords[de]=Rennstrecke;~%"
out)))))))))
- (home-page "http://trigger-rally.sourceforge.net")
+ (home-page "https://trigger-rally.sourceforge.net")
(synopsis "Fast-paced single-player racing game")
(description "Trigger-rally is a 3D rally simulation with great physics
for drifting on over 200 maps. Different terrain materials like dirt,
@@ -3300,7 +3296,7 @@ is very small), and shoot at the adversaries that keep appear on the screen.")
(invoke "./configure"
(string-append "--prefix=" out))))))))
(inputs (list ncurses))
- (home-page "http://www.asty.org/cmatrix")
+ (home-page "https://www.asty.org/cmatrix")
(synopsis "Simulate the display from \"The Matrix\"")
(description "CMatrix simulates the display from \"The Matrix\" and is
based on the screensaver from the movie's website. It works with terminal
@@ -3739,7 +3735,7 @@ match, cannon keep, and grave-itation pit.")
(install-file "libglkterm.a" lib))
#t))
(delete 'configure)))) ; no configure script
- (home-page "http://www.eblong.com/zarf/glk/")
+ (home-page "https://www.eblong.com/zarf/glk/")
(synopsis "Curses Implementation of the Glk API")
(description
"Glk defines a portable API for applications with text UIs. It was
@@ -4082,7 +4078,7 @@ This package expects the game(s) to be placed in subdirectories of
(define-public supertuxkart
(package
(name "supertuxkart")
- (version "1.3")
+ (version "1.4")
(source
(origin
(method url-fetch)
@@ -4091,7 +4087,7 @@ This package expects the game(s) to be placed in subdirectories of
version "/SuperTuxKart-" version "-src.tar.xz"))
(sha256
(base32
- "1z9z13zarv28h4jrmjna5hr6m9266pm7c2kgiwhqls01k06ypazf"))
+ "00qg5i9y4i5gdiiq1dbfsgp7dwj60zb5lkgi2d9p3x5s34j3k44q"))
(modules '((guix build utils)))
(snippet
;; Delete bundled library sources
@@ -4099,10 +4095,11 @@ This package expects the game(s) to be placed in subdirectories of
;; Supertuxkart uses modified versions of the Irrlicht engine
;; and the bullet library. The developers gave an explanation
;; here: http://forum.freegamedev.net/viewtopic.php?f=17&t=3906
- ;; FIXME: try to unbundle angelscript, libmcpp and libraqm
+ ;; FIXME: try to unbundle angelscript and libraqm
(for-each delete-file-recursively
'("lib/dnsc"
"lib/enet"
+ "lib/mcpp"
"lib/mojoal"
"lib/wiiuse"))
#t))))
@@ -4115,15 +4112,14 @@ This package expects the game(s) to be placed in subdirectories of
"-DUSE_CRYPTO_OPENSSL=TRUE"
;; In order to use the system ENet library, IPv6 support (added in
;; SuperTuxKart version 1.1) must be disabled.
- "-DUSE_IPV6=FALSE"
- ;; FIXME: needs libopenglrecorder
- "-DBUILD_RECORDER=0")))
+ "-DUSE_IPV6=FALSE")))
(inputs
`(("curl" ,curl)
("freetype" ,freetype)
("fribidi" ,fribidi)
("glew" ,glew)
("harfbuzz" ,harfbuzz)
+ ("libopenglrecorder" ,libopenglrecorder)
("libvorbis" ,libvorbis)
("libx11" ,libx11)
("libxrandr" ,libxrandr)
@@ -4137,8 +4133,7 @@ This package expects the game(s) to be placed in subdirectories of
("enet" ,enet)
("libjpeg" ,libjpeg-turbo)
("openssl" ,openssl)))
- (native-inputs
- (list pkg-config))
+ (native-inputs (list mcpp pkg-config python))
(home-page "https://supertuxkart.net/Main_Page")
(synopsis "3D kart racing game")
(description "SuperTuxKart is a 3D kart racing game, with a focus on
@@ -4412,14 +4407,14 @@ world}, @uref{http://evolonline.org, Evol Online} and
(define openttd-engine
(package
(name "openttd-engine")
- (version "12.2")
+ (version "13.0")
(source
(origin (method url-fetch)
(uri (string-append "https://cdn.openttd.org/openttd-releases/"
version "/openttd-" version "-source.tar.xz"))
(sha256
(base32
- "0p79mi6hnj9138911l56zxxzy7rqz02nmxbf455jc31sx46qyl41"))))
+ "0rxbsymfirkw2d9hn2lmi8yhlfx7qvpzhy7y7b48fw42w3hgi79k"))))
(build-system cmake-build-system)
(inputs
(list allegro
@@ -4865,7 +4860,7 @@ logging, so games can be viewed again.")
(symlink "README.md" "README")
(display (which "autoreconf")) (newline)
(invoke "autoreconf" "-vif"))))))
- (home-page "http://pinball.sourceforge.net")
+ (home-page "https://pinball.sourceforge.net")
(synopsis "Pinball simulator")
(description "The Emilia Pinball Project is a pinball simulator. There
are only two levels to play with, but they are very addictive.")
@@ -4899,7 +4894,7 @@ are only two levels to play with, but they are very addictive.")
(description "Pioneers is an emulation of the board game The Settlers of
Catan. It can be played on a local network, on the internet, and with AI
players.")
- (home-page "http://pio.sourceforge.net/")
+ (home-page "https://pio.sourceforge.net/")
(license license:gpl2+)))
(define-public einstein
@@ -5256,7 +5251,7 @@ fullscreen, use F5 or Alt+Enter.")
(inputs
`(("python" ,python-wrapper)
("sdl" ,(sdl-union (list sdl sdl-image sdl-mixer sdl-ttf sdl-net)))))
- (home-page "http://icculus.org/tennix/")
+ (home-page "https://icculus.org/tennix/")
(synopsis "Play tennis against the computer or a friend")
(description "Tennix is a 2D tennis game. You can play against the
computer or against another player using the keyboard. The game runs
@@ -5269,7 +5264,7 @@ in-window at 640x480 resolution or fullscreen.")
(define-public warzone2100
(package
(name "warzone2100")
- (version "4.0.1")
+ (version "4.3.3")
(source
(origin
(method url-fetch)
@@ -5277,7 +5272,7 @@ in-window at 640x480 resolution or fullscreen.")
version
"/warzone2100_src.tar.xz"))
(sha256
- (base32 "1f8a4kflslsjl8jrryhwg034h1yc9y3y1zmllgww3fqkz3aj4xik"))
+ (base32 "17p58wxwva0qp267hm1alas52jd9h74494wh01ahz880hscbjg1w"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -5314,31 +5309,32 @@ in-window at 640x480 resolution or fullscreen.")
(string-append "iV_DrawTextRotated(\"Press ESC to exit.\", "
"100, 100, 0.0f, font_regular);")))
#t)))))
- (native-inputs `(("asciidoc" ,asciidoc)
- ("asciidoctor" ,ruby-asciidoctor)
- ("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)
- ("unzip" ,unzip)
+ (native-inputs (list asciidoc
+ ruby-asciidoctor
+ gettext-minimal
+ pkg-config
+ unzip
;; 7z is used to create .zip archive, not `zip' as in version 3.2.*.
- ("p7zip" ,p7zip)))
- (inputs `(("curl" ,curl)
- ("fontconfig" ,fontconfig)
- ("freetype" ,freetype)
- ("glew" ,glew)
- ("harfbuzz" ,harfbuzz)
- ("libtheora" ,libtheora)
- ("libvorbis" ,libvorbis)
- ("libxrandr" ,libxrandr)
- ("libsodium" ,libsodium)
- ("miniupnpc" ,miniupnpc)
- ("openal" ,openal)
- ("physfs" ,physfs)
- ("qtbase" ,qtbase-5)
- ("qtscript" ,qtscript)
- ("openssl" ,openssl)
- ("sdl2" ,sdl2)
- ("sqlite" ,sqlite)
- ("utfcpp" ,utfcpp)))
+ p7zip))
+ (inputs (list opus
+ curl
+ fontconfig
+ freetype
+ glew
+ harfbuzz
+ libtheora
+ libvorbis
+ libxrandr
+ libsodium
+ miniupnpc
+ openal
+ physfs
+ qtbase-5
+ qtscript
+ openssl
+ sdl2
+ sqlite
+ utfcpp))
(home-page "https://wz2100.net")
(synopsis "3D Real-time strategy and real-time tactics game")
(description
@@ -5357,7 +5353,7 @@ tactics.")
(define-public widelands
(package
(name "widelands")
- (version "1.0")
+ (version "1.1")
(source
(origin
(method git-fetch)
@@ -5366,17 +5362,12 @@ tactics.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1hw51binnbia15mj1gzx1cbk3cw9r91sisqci2qzcy4ahxiadnw0"))
+ (base32 "07wbalwdmml9vdh9nh50svnsw4sdj9nnp32azbss8vzq5mxmzvbx"))
(modules '((guix build utils)))
(snippet
'(begin
(delete-file-recursively "src/third_party/minizip")
- #t))
- (patches
- ;; Use system Minizip. Patch is provided by Debian, and discussed
- ;; upstream at <https://github.com/widelands/widelands/issues/399>.
- (search-patches "widelands-system-wide_minizip.patch"
- "widelands-add-missing-map-include.patch"))))
+ #t))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags
@@ -5405,9 +5396,11 @@ tactics.")
#t)))))
(native-inputs
`(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(inputs
- `(("curl" ,curl)
+ `(("asio" ,asio)
+ ("curl" ,curl)
("boost" ,boost)
("glew" ,glew)
("icu4c" ,icu4c)
@@ -5501,7 +5494,7 @@ in strikes against the evil corporation.")
(native-inputs (list pkg-config))
(inputs (list gettext-minimal glu quesoglc
(sdl-union (list sdl sdl-image sdl-mixer))))
- (home-page "http://chromium-bsu.sourceforge.net/")
+ (home-page "https://chromium-bsu.sourceforge.net/")
(synopsis "Fast-paced, arcade-style, top-scrolling space shooter")
(description
"In this game you are the captain of the cargo ship Chromium B.S.U. and
@@ -6021,7 +6014,7 @@ for Un*x systems with X11.")
(define-public freeciv
(package
(name "freeciv")
- (version "3.0.0")
+ (version "3.0.6")
(source
(origin
(method url-fetch)
@@ -6033,13 +6026,13 @@ for Un*x systems with X11.")
(version-major+minor version) "/" version
"/freeciv-" version ".tar.xz")))
(sha256
- (base32 "1cm0530xmbqdhqkr89xb845cd756nillbdq53r3z5zpxsj18fapa"))))
+ (base32 "0hp4mkbcf5sipqkfjynls4m1qlh6kn0mp3jlqjrjwylmgcah3rs0"))))
(build-system gnu-build-system)
(inputs
(list curl cyrus-sasl gtk+ sdl-mixer zlib))
(native-inputs
(list pkg-config))
- (home-page "http://www.freeciv.org/")
+ (home-page "https://www.freeciv.org/")
(synopsis "Turn-based empire building strategy game")
(description "Freeciv is a turn-based empire building strategy game
inspired by the history of human civilization. The game commences in
@@ -6343,7 +6336,7 @@ over 100 user-created campaigns.")
("python" ,python-2)))
(native-inputs
(list swig))
- (home-page "http://kiki.sourceforge.net/")
+ (home-page "https://kiki.sourceforge.net/")
(synopsis "3D puzzle game")
(description "Kiki the nano bot is a 3D puzzle game. It is basically a
mixture of the games Sokoban and Kula-World. Your task is to help Kiki, a
@@ -6927,7 +6920,7 @@ at their peak of economic growth and military prowess.
(define-public open-adventure
(package
(name "open-adventure")
- (version "1.11")
+ (version "1.12")
(source
(origin
(method git-fetch)
@@ -6936,7 +6929,7 @@ at their peak of economic growth and military prowess.
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1n0fzrdlbc6px88qr574ww2q85xk43bv09jpmsskzv1l2cncwm37"))))
+ (base32 "07mg7cp12g27dw8sya17jqz6qp93q7c8zadsvym3w602z87g40in"))))
(build-system gnu-build-system)
(arguments
(list
@@ -7144,7 +7137,7 @@ Tales of Maj’Eyal offers engaging roguelike gameplay for the 21st century.")
(description "Quakespasm is a modern engine for id software's Quake 1.
It includes support for 64 bit CPUs, custom music playback, a new sound driver,
some graphical niceities, and numerous bug-fixes and other improvements.")
- (home-page "http://quakespasm.sourceforge.net/")
+ (home-page "https://quakespasm.sourceforge.net/")
(license license:gpl2+)))
(define-public vkquake
@@ -7727,7 +7720,7 @@ original.")
(string-append xonotic "/data"))
(copy-recursively "server"
(string-append xonotic "/server"))))))
- (home-page "http://xonotic.org")
+ (home-page "https://xonotic.org")
(synopsis "Data files for Xonotic")
(description
"Xonotic-data provides the data files required by the game Xonotic.")
@@ -7925,13 +7918,13 @@ games in the text adventure/interactive fiction genre. This version of Frotz
complies with standard 1.0 of Graham Nelson's specification. It plays all
Z-code games V1-V8, including V6, with sound support through libao, and uses
ncurses for text display.")
- (home-page "http://frotz.sourceforge.net")
+ (home-page "https://frotz.sourceforge.net")
(license license:gpl2+)))
(define-public naev
(package
(name "naev")
- (version "0.10.3")
+ (version "0.10.4")
(source
(origin
(method git-fetch)
@@ -7941,7 +7934,7 @@ ncurses for text display.")
(recursive? #t))) ; for game data
(file-name (git-file-name name version))
(sha256
- (base32 "0hqc2j7lf5ay461l164c63jncmjdvnkm2nf90246njimhz2in056"))))
+ (base32 "0lg8cmzdzzpmqgmh9a1v190vv4d15hwa0inyzdwsq5x8lyc13hyr"))))
(build-system meson-build-system)
(arguments
;; XXX: Do not add debugging symbols, which cause the build to fail.
@@ -8026,7 +8019,7 @@ scrolling. Maybe you'd like to experience what it's like to play Adventure on
a teletype. A much cooler use for compiling Frotz with the dumb interface is
that it can be wrapped in CGI scripting, PHP, and the like to allow people
to play games on webpages. It can also be made into a chat bot.")
- (home-page "http://frotz.sourceforge.net")
+ (home-page "https://frotz.sourceforge.net")
(license license:gpl2+)))
(define-public frotz-sdl
@@ -8086,7 +8079,7 @@ using SDL fully supports all these versions of the Z-Machine including the
graphical version 6. Graphics and sound are created through the use of the SDL
libraries. AIFF sound effects and music in MOD and OGG formats are supported
when packaged in Blorb container files or optionally from individual files.")
- (home-page "http://frotz.sourceforge.net")
+ (home-page "https://frotz.sourceforge.net")
(license license:gpl2+))))
(define-public frozen-bubble
@@ -8565,7 +8558,7 @@ download and unpack them separately.")
("zlib" ,zlib)))
(native-inputs
(list pkg-config zip))
- (home-page "http://btanks.sourceforge.net")
+ (home-page "https://btanks.sourceforge.net")
(synopsis "Multiplayer tank battle game")
(description "Battle Tanks (also known as \"btanks\") is a funny battle
game, where you can choose one of three vehicles and eliminate your enemy
@@ -8907,7 +8900,7 @@ fight each other on an arena-like map.")
(list hicolor-icon-theme
python-wrapper
(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf))))
- (home-page "http://www.flarerpg.org/")
+ (home-page "https://www.flarerpg.org/")
(synopsis "Action Roleplaying Engine")
(description "Flare (Free Libre Action Roleplaying Engine) is a simple
game engine built to handle a very specific kind of game: single-player 2D
@@ -10154,16 +10147,16 @@ can be downloaded from @url{https://zero.sjeng.org/best-network}.")
(define-public xmoto
(package
(name "xmoto")
- (version "0.6.1")
+ (version "0.6.2")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/xmoto/xmoto")
- (commit version)))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "00f5ha79lfa2iiaz66wl0hl5dapa1l15qdr7m7knzi0ll7j6z66n"))
+ (base32 "14z3yqpiyv4y5l37b12kf8ipgsmb9krb4b5d9adlrry0j43hd7wz"))
(modules '((guix build utils)
(ice-9 ftw)
(srfi srfi-1)))
@@ -10179,58 +10172,54 @@ can be downloaded from @url{https://zero.sjeng.org/best-network}.")
(cons* "." ".." keep))))
(substitute* "src/CMakeLists.txt"
(("add_subdirectory\\(.*?/vendor/(.+?)\".*" line library)
- (if (member library keep) line ""))))
- #t))))
+ (if (member library keep) line ""))))))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ;no test
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-hard-coded-directory
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "src/common/VFileIO.cpp"
- (("/usr/share")
- (string-append (assoc-ref outputs "out") "/share")))
- #t))
- (add-before 'build 'set-SDL
- ;; Set correct environment for SDL.
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "CPATH"
- (string-append
- (assoc-ref inputs "sdl") "/include/SDL:"
- (or (getenv "CPATH") "")))
- #t))
- (add-after 'install 'unbundle-fonts
- ;; Unbundle DejaVuSans TTF files.
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (let ((font-dir (string-append (assoc-ref inputs "font-dejavu")
- "/share/fonts/truetype/"))
- (target-dir (string-append (assoc-ref outputs "out")
- "/share/xmoto/Textures/Fonts/")))
- (for-each (lambda (f)
- (let ((font (string-append font-dir f))
- (target (string-append target-dir f)))
- (delete-file target)
- (symlink font target)))
- '("DejaVuSans.ttf" "DejaVuSansMono.ttf"))
- #t))))))
+ (list
+ #:tests? #f ;no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-hard-coded-directory
+ (lambda _
+ (substitute* "src/common/VFileIO.cpp"
+ (("/usr/share") (string-append #$output "/share")))))
+ (add-before 'build 'set-SDL
+ ;; Set correct environment for SDL.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CPATH"
+ (string-append
+ (search-input-directory inputs "/include/SDL2")
+ ":"
+ (or (getenv "CPATH") "")))))
+ (add-after 'install 'unbundle-fonts
+ ;; Unbundle DejaVuSans TTF files.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((font-dir (search-input-directory inputs
+ "/share/fonts/truetype/"))
+ (target-dir (string-append #$output
+ "/share/xmoto/Textures/Fonts/")))
+ (for-each (lambda (f)
+ (let ((font (string-append font-dir f))
+ (target (string-append target-dir f)))
+ (delete-file target)
+ (symlink font target)))
+ '("DejaVuSans.ttf" "DejaVuSansMono.ttf"))))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal pkg-config))
(inputs
- `(("bzip2" ,bzip2)
- ("curl" ,curl)
- ("font-dejavu" ,font-dejavu)
- ("glu" ,glu)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libxdg-basedir" ,libxdg-basedir)
- ("libxml2" ,libxml2)
- ("lua" ,lua-5.1)
- ("ode" ,ode)
- ("sdl" ,(sdl-union (list sdl sdl-mixer sdl-net sdl-ttf)))
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
+ (list bzip2
+ curl
+ font-dejavu
+ glu
+ libjpeg-turbo
+ libpng
+ libxdg-basedir
+ libxml2
+ lua
+ ode
+ (sdl-union (list sdl2 sdl2-mixer sdl2-net sdl2-ttf))
+ sqlite
+ zlib))
(home-page "https://xmoto.tuxfamily.org/")
(synopsis "2D motocross platform game")
(description
@@ -10335,7 +10324,7 @@ and chess engines.")
"ChessX is a chess database. With ChessX you can operate on your
collection of chess games in many ways: browse, edit, add, organize, analyze,
etc. You can also play games on FICS or against an engine.")
- (home-page "http://chessx.sourceforge.net/")
+ (home-page "https://chessx.sourceforge.net/")
(license license:gpl2+)))
(define-public stockfish
@@ -10426,7 +10415,7 @@ ChessX.")
(string-append "CFLAGS="
"-I" (assoc-ref %build-inputs "sdl-mixer")
"/include/SDL"))))
- (home-page "http://lgames.sourceforge.net/Barrage/")
+ (home-page "https://lgames.sourceforge.net/Barrage/")
(synopsis "Violent point-and-click shooting game with nice effects")
(description
"Barrage is a rather destructive action game that puts you on a shooting
@@ -10799,7 +10788,7 @@ inside the Zenith Colony.")
(build-system gnu-build-system)
(inputs
(list libx11 libxt xorgproto))
- (home-page "http://cgoban1.sourceforge.net/")
+ (home-page "https://cgoban1.sourceforge.net/")
(synopsis "Go client for X11")
(description "Provides a large set of Go-related services for X11:
@itemize
@@ -10859,7 +10848,7 @@ such as GnuGo.
`(("sdl" ,(sdl-union (list sdl sdl-mixer)))))
(native-inputs
(list imagemagick))
- (home-page "http://hcsoftware.sourceforge.net/passage/")
+ (home-page "https://hcsoftware.sourceforge.net/passage/")
(synopsis "Memento mori game")
(description
"Passage is meant to be a memento mori game. It presents an entire life,