summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm32
1 files changed, 22 insertions, 10 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d68f6aa451..2ed505bbc4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2435,7 +2435,7 @@ falling, themeable graphics and sounds, and replays.")
(define-public wesnoth
(package
(name "wesnoth")
- (version "1.14.7")
+ (version "1.14.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/wesnoth/wesnoth-"
@@ -2444,10 +2444,23 @@ falling, themeable graphics and sounds, and replays.")
"wesnoth-" version ".tar.bz2"))
(sha256
(base32
- "0j2yvkcggj5k0r2cqk8ndnj77m37a00srfd9qg7pdpqffbinqpj7"))))
+ "1mhdrlflxxyknf54lwdbvs7fazlc1scf7z6vxxa3j746fks533ga"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f)) ; no check target
+ `(#:tests? #f ;no check target
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'treat-boost-as-system-header
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((boost (assoc-ref inputs "boost")))
+ ;; Ensure Boost is treated as "system headers" to
+ ;; pacify compiler warnings induced by Boost headers.
+ (for-each (lambda (variable)
+ (setenv variable
+ (string-append boost "/include:"
+ (or (getenv variable)
+ ""))))
+ '("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH"))
+ #t))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
@@ -6815,13 +6828,12 @@ game field is extended to 4D space, which has to filled up by the gamer with
("innoextract" ,innoextract)))
(home-page "https://arx-libertatis.org/")
(synopsis "Port of Arx Fatalis, a first-person role-playing game")
- (description "Arx Libertatis is a cross-platform, open source port of Arx
-Fatalis, a 2002 first-person role-playing game / dungeon crawler developed by
-Arkane Studios. This port however does not include the game data, so you need
-to obtain a copy of the original Arx Fatalis or its demo to play Arx
-Libertatis. Arx Fatalis features crafting, melee and ranged combat, as well
-as a unique casting system where the player draws runes in real time to effect
-the desired spell.")
+ (description "Arx Libertatis is a cross-platform port of Arx Fatalis, a 2002
+first-person role-playing game / dungeon crawler developed by Arkane Studios.
+This port however does not include the game data, so you need to obtain a copy
+of the original Arx Fatalis or its demo to play Arx Libertatis. Arx Fatalis
+features crafting, melee and ranged combat, as well as a unique casting system
+where the player draws runes in real time to effect the desired spell.")
(license license:gpl3+)))
(define-public edgar