summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8f8eca29de..d56c4ad5e0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6523,7 +6523,15 @@ emerges from a sewer hole and pulls her below ground.")
(list
#:configure-flags
#~(list (string-append "-DCDOGS_DATA_DIR=" #$output
- "/share/cdogs-sdl/"))))
+ "/share/cdogs-sdl/"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-install-directory
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set\\(DATA_INSTALL_DIR \".\"\\)")
+ (string-append "set(DATA_INSTALL_DIR \""
+ #$output "/share/cdogs-sdl\")"))))))))
(native-inputs
(list pkg-config))
(inputs