summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 04b06c88ee..a2917a5f23 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1445,7 +1445,16 @@ fight Morgoth, the Lord of Darkness.")
(base32
"0wp06kcmknsnxz7bjnsndb8x062z7r23fb3yrnbfnj68qhz18y74"))
(patches (search-patches "pingus-boost-headers.patch"
- "pingus-sdl-libs-config.patch"))))
+ "pingus-sdl-libs-config.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "src/pingus/screens/demo_session.cpp"
+ (("#include <iostream>")
+ ;; std::function moved to <functional> with C++ 11.
+ ;; Remove this for versions newer than 0.7.6.
+ "#include <iostream>\n#include <functional>"))
+ #t))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("scons-python2" ,scons-python2)))