summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8a2ac9fcc5..ddfff4db8d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5811,6 +5811,14 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(string-append "LDFLAGS=-Wl,-rpath=" vulkanlib)
"-CQuake"))
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-for-new-vulkan
+ (lambda _
+ ;; Mimic upstream commit a869a22d9b51c68e for
+ ;; compatibility with newer vulkan-headers.
+ (substitute* "Quake/gl_rmisc.c"
+ (("VK_DYNAMIC_STATE_RANGE_SIZE")
+ "3"))
+ #t))
(delete 'configure)
(add-after 'unpack 'fix-makefile-paths
(lambda* (#:key outputs #:allow-other-keys)