summaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm66
1 files changed, 41 insertions, 25 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2c8b3c083f..349969654d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -62,6 +62,7 @@
;;; Copyright © 2021 David Pflug <david@pflug.io>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4348,7 +4349,7 @@ engine. When you start it you will be prompted to download a graphics set.")
(define openttd-opengfx
(package
(name "openttd-opengfx")
- (version "0.6.0")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
@@ -4356,7 +4357,7 @@ engine. When you start it you will be prompted to download a graphics set.")
version "/opengfx-" version "-source.tar.xz"))
(sha256
(base32
- "0qxc6gl2gxcrn1np88dnjgbaaakkkx96b13rcmy1spryc8c09hyr"))))
+ "0jgy8xv7r72m127qn09vr3rxhnbakl2990f7lldsk0d5d8n993vd"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags (list "CC=gcc"
@@ -4407,24 +4408,28 @@ OpenGFX provides you with...
(define openttd-opensfx
(package
(name "openttd-opensfx")
- (version "0.2.3")
+ (version "1.0.1")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://binaries.openttd.org/extra/opensfx/"
- version "/opensfx-" version "-source.tar.gz"))
+ "https://cdn.openttd.org/opensfx-releases/"
+ version "/opensfx-" version "-source.tar.xz"))
(sha256
(base32
- "03jxgp02ks31hmsdh4xh0xcpkb70ds8jakc9pfc1y9vdrdavh4p5"))))
+ "06vycppqcxbfdqlxzna5xr303zgcmpcvj6ylw5b2ws0ssph2f1s0"))))
(build-system gnu-build-system)
(native-inputs
`(("catcodec" ,catcodec)
- ("python" ,python-2)))
+ ("python" ,python-2)
+ ("tar" ,tar)))
(arguments
`(#:make-flags
- (list (string-append "INSTALL_DIR=" %output
- "/share/games/openttd/baseset/opensfx"))
+ (list (string-append "DIR_NAME=opensfx")
+ (string-append "TAR=" (assoc-ref %build-inputs "tar")
+ "/bin/tar"))
+ ;; The check phase only verifies md5sums, see openttd-opengfx.
+ #:tests? #f
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-reproducible
@@ -4434,45 +4439,56 @@ OpenGFX provides you with...
(substitute* "scripts/Makefile.def"
(("-cf") " --mtime=@0 -cf"))
#t))
- (delete 'configure))))
+ (delete 'configure)
+ (add-before 'build 'prebuild
+ (lambda _ (invoke "make" "opensfx.cat")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively "opensfx"
+ (string-append (assoc-ref outputs "out")
+ "/share/games/openttd/baseset"
+ "/opensfx")))))))
(home-page "http://dev.openttdcoop.org/projects/opensfx")
(synopsis "Base sounds for OpenTTD")
(description "OpenSFX is a set of free base sounds for OpenTTD which make
it possible to play OpenTTD without requiring the proprietary sound files from
the original Transport Tycoon Deluxe.")
- (license license:cc-sampling-plus-1.0)))
+ (license license:cc-by-sa3.0)))
(define openttd-openmsx
(package
(name "openttd-openmsx")
- (version "0.3.1")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://binaries.openttd.org/extra/openmsx/"
- version "/openmsx-" version "-source.tar.gz"))
+ "https://cdn.openttd.org/openmsx-releases/"
+ version "/openmsx-" version "-source.tar.xz"))
(sha256
(base32
- "0nskq97a6fsv1v6d62zf3yb8whzhqnlh3lap3va3nzvj7csjgf7c"))))
+ "0prjljsdgdxqdhhcriqskqha004ybs575xcjq80zha3pqnmrdk0k"))))
(build-system gnu-build-system)
(native-inputs
- `(("python" ,python-2)))
+ `(("grfcodec" ,grfcodec)
+ ("python" ,python-2)
+ ("tar" ,tar)))
(arguments
`(#:make-flags
- (list (string-append "INSTALL_DIR=" %output
- "/share/games/openttd/baseset"))
+ (list (string-append "DIR_NAME=openmsx")
+ (string-append "TAR=" (assoc-ref %build-inputs "tar")
+ "/bin/tar"))
+ ;; The check phase only verifies md5sums, see openttd-opengfx.
+ #:tests? #f
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-after 'install 'post-install
- ;; Rename openmsx-version to openmsx
+ (replace 'install
(lambda* (#:key outputs #:allow-other-keys)
- (let ((install-directory (string-append (assoc-ref outputs "out")
- "/share/games/openttd/baseset")))
- (rename-file (string-append install-directory "/openmsx-" ,version)
- (string-append install-directory "/openmsx"))
- #t))))))
+ (copy-recursively "openmsx"
+ (string-append (assoc-ref outputs "out")
+ "/share/games/openttd/baseset"
+ "/openmsx")))))))
(home-page "http://dev.openttdcoop.org/projects/openmsx")
(synopsis "Music set for OpenTTD")
(description "OpenMSX is a music set for OpenTTD which makes it possible