summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index ce6e3e7a83..a511cdbc45 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -706,7 +706,18 @@ It also includes runtime support libraries for these languages.")
"gcc-10-tree-sra-union-handling.patch"))
(modules '((guix build utils)))
(snippet gcc-canadian-cross-objdump-snippet)))
-
+ (arguments
+ (substitute-keyword-arguments (package-arguments gcc-8)
+ ((#:phases phases #~%standard-phases)
+ (if (target-hurd?)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'patch-hurd-libpthread
+ (lambda _
+ (define patch
+ #$(local-file
+ (search-patch "gcc-11-libstdc++-hurd-libpthread.patch")))
+ (invoke "patch" "--force" "-p1" "-i" patch))))
+ phases))))
(properties
`((compiler-cpu-architectures
("aarch64" ,@%gcc-11-aarch64-micro-architectures)