summaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index ea9b9e57f4..bb154cac62 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -745,7 +745,10 @@ It also includes runtime support libraries for these languages.")
(delete-file-recursively "texinfo")
(substitute* "configure"
(("host_tools=(.*)texinfo" _ before)
- (string-append "host_tools=" before)))))))
+ (string-append "host_tools=" before)))
+ ;; Fix building on arm* with gcc-4+
+ (substitute* "gcc/config/arm/arm.c"
+ (("arm_prog_mode") "arm_prgmode"))))))
(supported-systems (fold delete %supported-systems
'("powerpc64le-linux" "riscv64-linux")))
(native-inputs (list texinfo dejagnu))