summaryrefslogtreecommitdiff
path: root/gnu/packages/gd.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gd.scm')
-rw-r--r--gnu/packages/gd.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index 153e1c7f8b..3313ee68f2 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -40,17 +40,21 @@
;; Note: With libgd.org now pointing to github.com, genuine old
;; tarballs are no longer available. Notably, versions 2.0.x are
;; missing.
- (version "2.2.3")
+ (version "2.2.2")
(source (origin
(method url-fetch)
(uri (string-append
"https://github.com/libgd/libgd/releases/download/gd-"
version "/libgd-" version ".tar.xz"))
+ (patches (search-patches "gd-fix-test-on-i686.patch"
+ "gd-CVE-2016-5766.patch"
+ "gd-CVE-2016-6128.patch"
+ "gd-CVE-2016-6132.patch"
+ "gd-CVE-2016-6214.patch"))
(sha256
(base32
- "0g3xz8jpz1pl2zzmssglrpa9nxiaa7rmcmvgpbrjz8k9cyynqsvl"))
- (patches (search-patches "gd-fix-tests-on-i686.patch"))))
+ "1311g5mva2xlzqv3rjqjc4jjkn5lzls4skvr395h633zw1n7b7s8"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))