summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 1408cc4cb4..31fe95f6ad 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -317,3 +317,15 @@ from Markdown files.")
more interestingly, the maintenance of translations) using gettext tools on
areas where they were not expected like documentation.")
(license gpl2+)))
+
+(define-public po4a-minimal
+ (package/inherit po4a
+ (native-inputs
+ ;; Remove test dependencies, primarily to reduce the size of the
+ ;; dependency graph of the ‘guix’ package.
+ (modify-inputs (package-native-inputs po4a)
+ (delete "docbook-xml" "perl-test-pod" "texlive-updmap.cfg")))
+ (arguments
+ (substitute-keyword-arguments (package-arguments po4a)
+ ((#:tests? _ #t) #f)))
+ (properties '((hidden? . #t)))))