summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm34
1 files changed, 19 insertions, 15 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index e5a2c6e479..a4c8ef1a34 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -34,37 +34,41 @@
(define-public gnu-gettext
(package
(name "gettext")
- (version "0.18.3.2")
+ (version "0.19.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gettext/gettext-"
version ".tar.gz"))
(sha256
(base32
- "1my5njl7mp663abpdn8qsm5i462wlhlnb5q50fmhgd0fsr9f996i"))))
+ "1ih104j74dw90cb18ym50qlks3k6632zsiv2c94fnpyzbgcp2x18"))))
(build-system gnu-build-system)
(inputs
`(("expat" ,expat)))
(arguments
`(#:phases (alist-cons-before
- 'configure 'link-expat
- (lambda _
- (substitute* "gettext-tools/configure"
- (("LIBEXPAT=\"-ldl\"") "LIBEXPAT=\"-ldl -lexpat\"")
- (("LTLIBEXPAT=\"-ldl\"") "LTLIBEXPAT=\"-ldl -lexpat\"")))
- (alist-cons-before
'check 'patch-tests
(lambda* (#:key inputs #:allow-other-keys)
- (let ((bash (which "sh")))
- (substitute* (find-files "gettext-tools/tests"
- "^msgexec-[0-9]")
+ (let* ((bash (which "sh")))
+ (substitute*
+ (find-files "gettext-tools/tests"
+ "^(lang-sh|msg(exec|filter)-[0-9])")
(("#![[:blank:]]/bin/sh")
(format #f "#!~a" bash)))
- (substitute* (find-files "gettext-tools/gnulib-tests"
- "posix_spawn")
+
+ (substitute* (cons "gettext-tools/src/msginit.c"
+ (find-files "gettext-tools/gnulib-tests"
+ "posix_spawn"))
(("/bin/sh")
- bash))))
- %standard-phases))))
+ bash))
+
+ (substitute* "gettext-tools/src/project-id"
+ (("/bin/pwd")
+ "pwd"))))
+ %standard-phases)
+
+ ;; When tests fail, we want to know the details.
+ #:make-flags '("VERBOSE=yes")))
(home-page "http://www.gnu.org/software/gettext/")
(synopsis "Tools and documentation for translation")
(description