summaryrefslogtreecommitdiff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index b75c20c751..d5fd197922 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -111,6 +111,15 @@
(("/bin/pwd")
"pwd"))
+ ;; Work around Gnulib test failures on armhf-linux.
+ #$@(if (target-arm32?)
+ #~((with-directory-excursion "gettext-tools"
+ (invoke "patch" "--force" "-p1" "-i"
+ #$(local-file
+ (search-patch
+ "coreutils-gnulib-tests.patch")))))
+ '())
+
#t)))))
;; When tests fail, we want to know the details.