summaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index a00448a8c6..dcbed69e3e 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -39,12 +39,12 @@
(define-public lcms
(package
(name "lcms")
- (replacement lcms/fixed)
(version "2.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/lcms/lcms/" version
"/lcms2-" version ".tar.gz"))
+ (patches (search-patches "lcms-fix-out-of-bounds-read.patch"))
(sha256 (base32
"1c8lgq8gfs3nyplvbx9k8wzfj6r2bqi3f611vb1m8z3476454wji"))))
(build-system gnu-build-system)
@@ -59,14 +59,6 @@ Consortium standard (ICC), approved as ISO 15076-1.")
(license license:x11)
(home-page "http://www.littlecms.com/")))
-(define lcms/fixed
- (package
- (inherit lcms)
- (source
- (origin
- (inherit (package-source lcms))
- (patches (search-patches "lcms-fix-out-of-bounds-read.patch"))))))
-
(define-public libpaper
(package
(name "libpaper")
@@ -177,9 +169,9 @@ printing, and psresize, for adjusting page sizes.")
(add-after 'configure 'patch-config-files
(lambda _
(substitute* "base/all-arch.mak"
- (("/bin/sh") (which "bash")))
+ (("/bin/sh") (which "sh")))
(substitute* "base/unixhead.mak"
- (("/bin/sh") (which "bash")))))
+ (("/bin/sh") (which "sh")))))
(add-after 'configure 'remove-doc-reference
(lambda _
;; Don't retain a reference to the 'doc' output in 'gs'.