summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index beb43f0ae2..af5adb8bfd 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -215,7 +215,7 @@ provided, as well as a framework to add new color models and data types.")
(define-public gegl
(package
(name "gegl")
- (version "0.4.36")
+ (version "0.4.42")
(source
(origin
(method url-fetch)
@@ -229,7 +229,7 @@ provided, as well as a framework to add new color models and data types.")
(version-major+minor version)
"/gegl-" version ".tar.xz")))
(sha256
- (base32 "19ic3fv0j8ysxxw7bx7gy3l8l8l9ldrvbzxfmmc24w67vh68mmbg"))))
+ (base32 "0bg0vlmj4n9x1291b9fsjqxsal192zlg48pa57f6xid6p863ma5b"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
@@ -302,6 +302,19 @@ buffers.")
"doc")) ; 9 MiB of gtk-doc HTML
(arguments
(list
+ #:modules `((ice-9 popen)
+ (ice-9 rdelim)
+ ,@%gnu-build-system-modules)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-gcc-reference
+ ;; Avoid reference to GCC.
+ (lambda _
+ (let* ((port (open-input-pipe "gcc -v 2>&1 | tail -n 1"))
+ (cc-version (read-line port)))
+ (close-pipe port)
+ (substitute* "app/gimp-version.c"
+ (("CC_VERSION") (string-append "\"" cc-version "\"")))))))
#:configure-flags
#~(list (string-append "--with-html-dir=" #$output "/share/gtk-doc/html")