summaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index fc2c8ff516..c98f686d41 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -43,29 +44,32 @@
(define-public babl
(package
(name "babl")
- (version "0.1.38")
+ (version "0.1.40")
(source (origin
(method url-fetch)
(uri (list (string-append "https://download.gimp.org/pub/babl/"
- "0.1/babl-" version ".tar.bz2")
- (string-append "http://ftp.gtk.org/pub/babl/0.1/babl-"
- version ".tar.bz2")
- (string-append "ftp://ftp.gtk.org/pub/babl/0.1/babl-"
- version ".tar.bz2")))
+ (version-major+minor version)
+ "/babl-" version ".tar.bz2")
+ (string-append "http://ftp.gtk.org/pub/babl/"
+ (version-major+minor version)
+ "/babl-" version ".tar.bz2")
+ (string-append "ftp://ftp.gtk.org/pub/babl/"
+ (version-major+minor version)
+ "/babl-" version ".tar.bz2")))
(sha256
(base32
- "11pfbyzq20596p9sgwraxspg3djg1jzz6wvz4bapf0yyr97jiyd0"))))
+ "08cdl6rcfvkhqsnhb214xzr0wbrv0956xzlrzqxcb1k1madgjanh"))))
(build-system gnu-build-system)
(home-page "http://gegl.org/babl/")
(synopsis "Image pixel format conversion library")
(description
- "Babl is a dynamic, any to any, pixel format translation library.
-It allows converting between different methods of storing pixels known as
-pixel formats that have with different bitdepths and other data
-representations, color models and component permutations.
+ "Babl is a dynamic, any-to-any pixel format translation library.
+It allows converting between different methods of storing pixels, known as
+@dfn{pixel formats}, that have different bit depths and other data
+representations, color models, and component permutations.
A vocabulary to formulate new pixel formats from existing primitives is
-provided as well as the framework to add new color models and data types.")
+provided, as well as a framework to add new color models and data types.")
(license license:lgpl3+)))
(define-public gegl