summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 9325d41907..86be6e0bb1 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -298,7 +298,8 @@ also known as DXTn or DXTC) for Mesa.")
libxvmc
llvm-for-mesa
wayland
- wayland-protocols))
+ wayland-protocols
+ `(,zstd "lib")))
(native-inputs
(list bison
flex
@@ -362,6 +363,9 @@ svga,swrast,virgl")))
;; 21.3.x releases to avoid functionality regressions.
"-Dvideo-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc"
+ ;; Enable ZSTD compression for shader cache.
+ "-Dzstd=enabled"
+
;; Also enable the tests.
"-Dbuild-tests=true"