summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm34
1 files changed, 9 insertions, 25 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 66db679342..d6d127d765 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
-;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -268,7 +268,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "21.3.8")
+ (version "22.1.2")
(source
(origin
(method url-fetch)
@@ -280,7 +280,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "19wx5plk6z0hhi0zdzxjx8ynl3lhlc5mbd8vhwqyk92kvhxjf3g7"))
+ "1smrvvh8l7xcccwfbccx9k0ihzh1whrnnwsmqb7i0gba99mj4w89"))
(patches
(search-patches "mesa-skip-tests.patch"))))
(build-system meson-build-system)
@@ -305,7 +305,7 @@ also known as DXTn or DXTC) for Mesa.")
wayland-protocols)
;; TODO: Resort alphabetically.
;; Note: update the 'clang' input of mesa-opencl when bumping this.
- (list llvm-11)))
+ (list llvm)))
(native-inputs
(append (list bison
flex
@@ -327,10 +327,10 @@ also known as DXTn or DXTC) for Mesa.")
("armhf-linux"
;; Freedreno FTBFS when built on a 64-bit machine.
'("-Dgallium-drivers=etnaviv,kmsro,lima,nouveau,panfrost,r300,r600,swrast,tegra,v3d,vc4,virgl"))
- ((or "powerpc64le-linux" "powerpc-linux" "riscv64-linux")
+ ((or "powerpc64le-linux" "powerpc-linux")
'("-Dgallium-drivers=nouveau,r300,r600,radeonsi,swrast,virgl"))
(_
- '("-Dgallium-drivers=iris,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
+ '("-Dgallium-drivers=auto")))
;; Enable various optional features. TODO: opencl requires libclc,
;; omx requires libomxil-bellagio
"-Dplatforms=x11,wayland"
@@ -347,14 +347,10 @@ also known as DXTn or DXTC) for Mesa.")
;; Explicitly enable Vulkan on some architectures.
,@(match (%current-system)
- ((or "i686-linux" "x86_64-linux")
- '("-Dvulkan-drivers=intel,amd"))
((or "powerpc64le-linux" "powerpc-linux")
'("-Dvulkan-drivers=amd,swrast"))
("aarch64-linux"
'("-Dvulkan-drivers=freedreno,amd,broadcom,swrast"))
- ("riscv64-linux"
- '("-Dvulkan-drivers=amd,swrast"))
(_
'("-Dvulkan-drivers=auto")))
@@ -364,15 +360,8 @@ also known as DXTn or DXTC) for Mesa.")
;; Also enable the tests.
"-Dbuild-tests=true"
- ;; on non-intel systems, drop i915 and i965
- ;; from the default dri drivers
- ,@(match (%current-system)
- ((or "x86_64-linux" "i686-linux")
- '("-Ddri-drivers=i915,i965,nouveau,r200,r100"))
- (_
- '("-Ddri-drivers=nouveau,r200,r100")))
-
- "-Dllvm=enabled") ; default is x86/x86_64 only
+ ;; Enable LLVM; default is x86/x86_64 only.
+ "-Dllvm=enabled")
;; XXX: 'debugoptimized' causes LTO link failures on some drivers. The
;; documentation recommends using 'release' for performance anyway.
@@ -420,11 +409,6 @@ also known as DXTn or DXTC) for Mesa.")
;; This test times out and receives SIGTERM.
(substitute* "src/amd/common/meson.build"
(("and not with_platform_windows") "and with_platform_windows"))))
- ("i686-linux"
- ;; Disable new test from Mesa 19 that fails on i686. Upstream
- ;; report: <https://bugs.freedesktop.org/show_bug.cgi?id=110612>.
- `((substitute* "src/util/tests/format/meson.build"
- (("'u_format_test',") ""))))
("aarch64-linux"
;; The ir3_disasm test segfaults.
;; The simplest way to skip it is to run a different test instead.
@@ -523,7 +507,7 @@ from software emulation to complete hardware acceleration for modern GPUs.")
(prepend libclc)))
(native-inputs
(modify-inputs (package-native-inputs mesa)
- (prepend clang-11)))))
+ (prepend clang)))))
(define-public mesa-opencl-icd
(package/inherit mesa-opencl