summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 79cbf71168..9930de87de 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -105,7 +105,7 @@ as ASCII text.")
("libxi" ,libxi)
("libxrandr" ,libxrandr)
("libxxf86vm" ,libxxf86vm)
- ("inputproto" ,inputproto)
+ ("xorgproto" ,xorgproto)
("xinput" ,xinput)))
(propagated-inputs
;; Headers from Mesa and GLU are needed.
@@ -240,19 +240,17 @@ also known as DXTn or DXTC) for Mesa.")
"mesa-skip-disk-cache-test.patch"))))
(build-system gnu-build-system)
(propagated-inputs
- `(("glproto" ,glproto)
- ;; The following are in the Requires.private field of gl.pc.
+ `(;; The following are in the Requires.private field of gl.pc.
("libdrm" ,libdrm)
("libvdpau" ,libvdpau)
("libx11" ,libx11)
("libxdamage" ,libxdamage)
("libxfixes" ,libxfixes)
("libxshmfence" ,libxshmfence)
- ("libxxf86vm" ,libxxf86vm)))
+ ("libxxf86vm" ,libxxf86vm)
+ ("xorgproto" ,xorgproto)))
(inputs
`(("expat" ,expat)
- ("dri2proto" ,dri2proto)
- ("dri3proto" ,dri3proto)
("libelf" ,libelf) ;required for r600 when using llvm
("libva" ,(force libva-without-mesa))
("libxml2" ,libxml2)
@@ -264,7 +262,6 @@ also known as DXTn or DXTC) for Mesa.")
(_
`()))
("makedepend" ,makedepend)
- ("presentproto" ,presentproto)
("wayland" ,wayland)
("wayland-protocols" ,wayland-protocols)))
(native-inputs
@@ -478,9 +475,11 @@ glxgears, glxheads, and glxinfo.")
"0r37fg2s1f0jrvwh6c8cz5x6v4wqmhq42qm15cs9qs349q5c6wn5"))
(modules '((guix build utils)))
(snippet
- '(substitute* "config/Makefile.linux"
- (("= cc") "= gcc")
- (("/lib64") "/lib")))))
+ '(begin
+ (substitute* "config/Makefile.linux"
+ (("= cc") "= gcc")
+ (("/lib64") "/lib"))
+ #t))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases (delete 'configure))