summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm27
1 files changed, 24 insertions, 3 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index b863283606..01241cd88e 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 ng0 <ng0@n0.is>
-;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -268,6 +268,7 @@ also known as DXTn or DXTC) for Mesa.")
("libxvmc" ,libxvmc)
,@(match (%current-system)
((or "x86_64-linux" "i686-linux")
+ ;; Note: update the 'clang' input of mesa-opencl when bumping this.
`(("llvm" ,llvm-9)))
(_
`()))
@@ -435,7 +436,7 @@ from software emulation to complete hardware acceleration for modern GPUs.")
`(("libclc" ,libclc)
,@(package-inputs mesa)))
(native-inputs
- `(("clang" ,clang-8)
+ `(("clang" ,clang-9)
,@(package-native-inputs mesa)))))
(define-public mesa-opencl-icd
@@ -603,6 +604,26 @@ extension functionality is exposed in a single header file.")
OpenGL graphics API.")
(license license:lgpl3+)))
+(define-public guile3.0-opengl
+ (package
+ (inherit guile-opengl)
+ (name "guile3.0-opengl")
+ (arguments
+ (substitute-keyword-arguments (package-arguments guile-opengl)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'build-with-guile-3.0
+ (lambda _
+ (substitute* "configure"
+ (("_guile_versions_to_search=\"")
+ "_guile_versions_to_search=\"3.0 "))
+ #t))))))
+ (inputs
+ `(("guile" ,guile-3.0)
+ ("mesa" ,mesa)
+ ("glu" ,glu)
+ ("freeglut" ,freeglut)))))
+
(define-public libepoxy
(package
(name "libepoxy")
@@ -712,7 +733,7 @@ OpenGL.")
("libxinerama" ,libxinerama)
("libxcursor" ,libxcursor)
("libxxf86vm" ,libxxf86vm)))
- (home-page "http://www.glfw.org")
+ (home-page "https://www.glfw.org")
(synopsis "OpenGL application development library")
(description
"GLFW is a library for OpenGL, OpenGL ES and Vulkan development for