summaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm42
1 files changed, 13 insertions, 29 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index a3862f1ec3..fce44b43e2 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
-;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -33,6 +33,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages guile)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages llvm)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages video)
@@ -197,7 +198,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "13.0.3")
+ (version "13.0.5")
(source
(origin
(method url-fetch)
@@ -205,7 +206,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz"))
(sha256
(base32
- "03m4gc6qc50lb0ic06f83r3yl0x4lmj2zjq3sl60vl3nq7jqpanr"))
+ "11zgynii1wz17131ml1mmblpwib8m88zz2jwi5h5llh1r3iagkmz"))
(patches
(search-patches "mesa-wayland-egl-symbols-check-mips.patch"))))
(build-system gnu-build-system)
@@ -230,14 +231,15 @@ also known as DXTn or DXTC) for Mesa.")
("makedepend" ,makedepend)
("presentproto" ,presentproto)
("s2tc" ,s2tc)
+ ("llvm" ,llvm)
("wayland" ,wayland)))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python-2)))
(arguments
`(#:configure-flags
- '(;; drop r300 from default gallium drivers, as it requires llvm
- "--with-gallium-drivers=r600,svga,swrast,nouveau,virgl"
+ '("--with-gallium-drivers=i915,r300,r600,svga,swrast,nouveau,virgl"
+ "--enable-gallium-llvm"
;; Enable various optional features. TODO: opencl requires libclc,
;; omx requires libomxil-bellagio
"--with-egl-platforms=x11,drm,wayland"
@@ -456,25 +458,20 @@ OpenGL graphics API.")
(define-public libepoxy
(package
(name "libepoxy")
- (version "1.3.1")
+ (version "1.4.0")
(source (origin
(method url-fetch)
(uri (string-append
- "https://github.com/anholt/libepoxy/archive/v"
+ "https://github.com/anholt/libepoxy/releases/download/v"
+ (version-major+minor version) "/libepoxy-"
version
- ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ ".tar.xz"))
(sha256
(base32
- "1d1brhwfmlzgnphmdwlvn5wbcrxsdyzf1qfcf8nb89xqzznxs037"))
- (patches (search-patches "libepoxy-gl-null-checks.patch"))))
+ "0hdbaapbxjjfdqsdvag460kfjvs800da5sngi2sc46wj9aqhda95"))))
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after
- 'unpack 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vif"))))
(add-before
'configure 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -485,23 +482,10 @@ OpenGL graphics API.")
(substitute* (find-files "." "\\.[ch]$")
(("libGL.so.1") (string-append mesa "/lib/libGL.so.1"))
(("libEGL.so.1") (string-append mesa "/lib/libEGL.so.1")))
-
- ;; XXX On armhf systems, we must add "GLIBC_2.4" to the list of
- ;; versions in test/dlwrap.c:dlwrap_real_dlsym. It would be
- ;; better to make this a normal patch, but for now we do it here
- ;; to prevent rebuilding on other platforms.
- ,@(if (string-prefix? "arm" (or (%current-target-system)
- (%current-system)))
- '((substitute* '"test/dlwrap.c"
- (("\"GLIBC_2\\.0\"") "\"GLIBC_2.0\", \"GLIBC_2.4\"")))
- '())
#t))))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
+ `(("pkg-config" ,pkg-config)
("python" ,python)))
(inputs
`(("mesa" ,mesa)))